[YAM - Yet Another Mailer] Topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/topic/10 <p> Moving messages after a find, scripts </p> en-us YAM - Yet Another Mailer http://yam.ch/chrome/site/yam.gif http://yam.ch/discussion/topic/10 Trac 1.0.2 - DiscussionPlugin JosDuchIt Mon, 14 Jun 2010 05:55:29 GMT Topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/topic/10#topic http://yam.ch/discussion/topic/10#topic <p> Hi, I was able with previous versions of Yam to select the messages found in some drawer then move them to an other one in one operation. In 2.6 that does not seem to work anymore. The 'Move' buttons is not highlighted (nly New, Get and Send) after such a "Select matched" This is pretty annoying. Other question; can only arexx scripts be used any more? I was using a RUN "MyBrowser %p" before (doublecklicking an <acronym title="Uniform Resource Locator">URL</acronym>) </p> Topic JosDuchIt Thu, 17 Jun 2010 06:39:57 GMT Reply #29 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/29#message29 http://yam.ch/discussion/message/29#message29 <p> t was more simple than that. </p> <p> I forgot to set to "AmigaDOS" and had "Arexx" visible in the choice gadget. </p> <p> Sorry about wasting your time. </p> <p> Joseph </p> Message thboeckel Thu, 17 Jun 2010 06:30:39 GMT Reply #28 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/28#message28 http://yam.ch/discussion/message/28#message28 <blockquote class="citation"> <p> basically i think that i changed RUN OWB to RUN OWBLauncher. Reverting to RUN OWB works OK </p> </blockquote> <p> If "run owb" works, but "run owblauncher" does not, then this is an issue of OWBLauncher being unable to locate the OWB executable. Most probably OWBLauncher will look for the OWB executable in the current directory and the standard Shell command search path only. When being run by YAM the current directory most probably is YAM's program directory. I suggest to use a script which sets the currect directory to OWB's programm directory (where OWBLauncher should reside, too) and then runs OWBLauncher. </p> Message JosDuchIt Wed, 16 Jun 2010 12:32:55 GMT Reply #27 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/27#message27 http://yam.ch/discussion/message/27#message27 <blockquote class="citation"> <p> So do I get you right? It is working now that you have updated OWB? </p> </blockquote> <p> Yes indeed. basically i think that i changed RUN OWB to RUN OWBLauncher. Reverting to RUN OWB works OK </p> <blockquote class="citation"> <p> Well, I can't really answer that. I really have to see which commands you exactly entered and what you expect YAM to perform on that action. </p> </blockquote> <p> Basically I do intend to lauch Gui4Cli scripts (eg when reading a mail). These would be launched as RUN guis:gui Myscript.gc %sender Since CLI commands like 'RUN echo "hello"' and 'RUN info' failed i did not push the idea. I will do a real try and let you know the results. </p> <p> Thanks for your help and programming efforts </p> <p> Joseph </p> Message damato Wed, 16 Jun 2010 10:23:24 GMT Reply #26 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/26#message26 http://yam.ch/discussion/message/26#message26 <blockquote class="citation"> <p> Hi, I am well aware of the <acronym title="Frequently Asked Questions">FAQ</acronym> directive to set up OpenURL I did use this however in YAM2.5 RUN sys:utilities/OWB3.22/OWB %p and that worked OK. </p> <p> I thought i did lose this possibility in 2.6 , but it seems that it may be due to a non YAM issue ( i downloaded new versions of OWB and changed the command, i don't know anymore how, but the previous command works well with YAM2.6 too. </p> </blockquote> <p> So do I get you right? It is working now that you have updated OWB? </p> <blockquote class="citation"> <p> I tested however commands like RUN echo "hello" and RUN info both of which fail. Maybe the question is why some CLI commands work and others not. Thanks for responding </p> </blockquote> <p> Well, I can't really answer that. I really have to see which commands you exactly entered and what you expect YAM to perform on that action. </p> Message JosDuchIt Tue, 15 Jun 2010 16:07:39 GMT Reply #25 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/25#message25 http://yam.ch/discussion/message/25#message25 <p> Hi, I am well aware of the <acronym title="Frequently Asked Questions">FAQ</acronym> directive to set up OpenURL I did use this however in YAM2.5 RUN sys:utilities/OWB3.22/OWB %p and that worked OK. </p> <p> I thought i did lose this possibility in 2.6 , but it seems that it may be due to a non YAM issue ( i downloaded new versions of OWB and changed the command, i don't know anymore how, but the previous command works well with YAM2.6 too. I tested however commands like RUN echo "hello" and RUN info both of which fail. Maybe the question is why some CLI commands work and others not. Thanks for responding </p> Message damato Tue, 15 Jun 2010 13:25:14 GMT Reply #24 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/24#message24 http://yam.ch/discussion/message/24#message24 <blockquote class="citation"> <p> Can you describe the ARexx issue a bit more detailed? I can perfectly specify a script which will be invoked when I double click a <acronym title="Uniform Resource Locator">URL</acronym>. </p> </blockquote> <p> think what he is trying to say is that non-ARexx scripts are not working because he has specified "Run 'MyBrowser %p'" as the doubleclicking action for clicking on an <acronym title="Uniform Resource Locator">URL</acronym>. However, it is also unclear to me why this should not work. In addition, if he has installed openurl he does normally also not need to specify that manual action as OpenURL would handle that all for him. So please see the following <acronym title="Frequently Asked Questions">FAQ</acronym> entry for more information on how to setup YAM for proper OpenURL support: </p> <p> <a href="http://yam.ch/wiki/FAQ/Using%20YAM#DoubleclickinganURLdoesntseemtopopupmyfavouritewebbrowser">http://yam.ch/wiki/FAQ/Using%20YAM#DoubleclickinganURLdoesntseemtopopupmyfavouritewebbrowser</a> </p> Message thboeckel Tue, 15 Jun 2010 12:59:54 GMT Reply #23 to topic #10 - Moving messages after a find, scripts http://yam.ch/discussion/message/23#message23 http://yam.ch/discussion/message/23#message23 <p> The "disabled move button" issue will be fixed in the next nightly build. </p> <p> Can you describe the ARexx issue a bit more detailed? I can perfectly specify a script which will be invoked when I double click a <acronym title="Uniform Resource Locator">URL</acronym>. </p> Message