[YAM - Yet Another Mailer] Topic #14 - Greek unicode in YAM http://yam.ch/discussion/topic/14 <p> Greek unicode in YAM </p> en-us YAM - Yet Another Mailer http://yam.ch/chrome/site/yam.gif http://yam.ch/discussion/topic/14 Trac 1.0.1 - DiscussionPlugin vulture Mon, 18 Jan 2010 11:15:16 GMT Topic #14 - Greek unicode in YAM http://yam.ch/discussion/topic/14#topic http://yam.ch/discussion/topic/14#topic <p> I'm not sure if it's been discussed before (not as far as I could tell by my search) , but I just can't see correct Unicode greek emails in YAM (OS4.1u1, latest codesets.library). I've tried everything i could think of, latest nightly build with UTF-8, iso-7, Windows 1252, I've placed greek fonts in MUI settings, I've changed the encoding in the typemanager....I'm stuck! What is surprising is that simplemail reads everything correctly out of the box!?! Any idea what I'm doing wrong here? Thx! </p> Topic vulture Fri, 22 Jan 2010 16:38:31 GMT Reply #42 to topic #14 - Greek unicode in YAM http://yam.ch/discussion/message/42#message42 http://yam.ch/discussion/message/42#message42 <p> Of course that was the problem. I had thought that greek are not standard ascii and, well, since we share some letters with the cyrilic alphabet that it would help <img src="/chrome/emoticons/annoyed.png" alt=":/" class="emoticon" width="18" height="18" style="vertical-align: middle" /> I also had never used the update inex thing so, I didn't think that'd correct the list problem. Many many thx! <img src="/chrome/emoticons/smile.png" alt=":)" class="emoticon" width="18" height="18" style="vertical-align: middle" /> </p> Message thboeckel Fri, 22 Jan 2010 07:19:55 GMT Reply #41 to topic #14 - Greek unicode in YAM http://yam.ch/discussion/message/41#message41 http://yam.ch/discussion/message/41#message41 <p> Posting the same reply here: </p> <blockquote class="citation"> <p> So, after unchecking the "replace unknown ascii characters" and "automatic detection of cyrilic" I finally have readable greek text in all the emails </p> </blockquote> <p> As far as I know automatic detection of cyrillic characters should be enabled for russian people only. Nobody else should really need this option. This is why it is named "cyrillic" only and not "cyrillic and greek and thai and all other non-latin". </p> <p> And by enabling "Replace unknown <acronym title="American Standard Code for Information Interchange">ASCII</acronym> characters" you get exactly what you requested: every non-<acronym title="American Standard Code for Information Interchange">ASCII</acronym> character is replaced by a "similar" looking character, if possible. Special unicode characters like many czech characters for example, which are looking like plain latin character with some additional accents, will be converted to plain latin characters. For most users this makes it possible to display such a text in quite a readable form. For greek characters this causes much more trouble as greek uses almost no latin like characters and hence all of them are converted to "?" because there is no "similar" latin character. </p> <blockquote class="citation"> <p> I've tried so far. the problem remains on the subject line at the list of inbox. You may see the problem in the screengrab I've attached. The text below is fine but the selected message has ?????????? for subject in the inbox list. I tried to change fonts in MUI to no avail. Of course I've also attached the email in question as an example. </p> </blockquote> <p> Perform an index rescan of the folder with "Replace unknown <acronym title="American Standard Code for Information Interchange">ASCII</acronym> characters" disabled. YAM makes heavy use of its cached index and this also includes the formerly converted characters. A rescan should give you your favored greek characters back. </p> Message vulture Thu, 21 Jan 2010 20:38:05 GMT Reply #40 to topic #14 - Greek unicode in YAM http://yam.ch/discussion/message/40#message40 http://yam.ch/discussion/message/40#message40 <p> Email sent with screenshot as well as the problem has changed a bit after altering some settings, reduced to subject only at the inbox list. Thanks! <img src="/chrome/emoticons/smile.png" alt=":)" class="emoticon" width="18" height="18" style="vertical-align: middle" /> </p> Message thboeckel Wed, 20 Jan 2010 20:08:32 GMT Reply #39 to topic #14 - Greek unicode in YAM http://yam.ch/discussion/message/39#message39 http://yam.ch/discussion/message/39#message39 <p> Export the mail to a file and attach it to a mail to both Jens (damato at light-speed.de) and me (tboeckel at gmx.de). Forwarding could work as well, but with an attached file we can be sure to receive the mail unchanged. </p> Message vulture Wed, 20 Jan 2010 16:31:00 GMT Reply #38 to topic #14 - Greek unicode in YAM http://yam.ch/discussion/message/38#message38 http://yam.ch/discussion/message/38#message38 <p> How do I post that in the forum? Copy n paste the text from the email body? Or would it be better if i forwarded you an example email to your email address? Thx! </p> Message thboeckel Wed, 20 Jan 2010 15:46:31 GMT Reply #37 to topic #14 - Greek unicode in YAM http://yam.ch/discussion/message/37#message37 http://yam.ch/discussion/message/37#message37 <p> Could you please provide an example mail exported from YAM? I don't receive any greek mails or mails with other non-latin characters, so there is very little for me check right now to reproduce this issue. </p> Message