YAM - Yet Another Mailer (#2) - Moving messages after a find, scripts (#10) - Message List

Moving messages after a find, scripts
 solved

Hi, I was able with previous versions of Yam to select the messages found in some drawer then move them to an other one in one operation. In 2.6 that does not seem to work anymore. The 'Move' buttons is not highlighted (nly New, Get and Send) after such a "Select matched" This is pretty annoying. Other question; can only arexx scripts be used any more? I was using a RUN "MyBrowser %p" before (doublecklicking an URL)

Tree View Flat View (newer first) Flat View (older first)
  • Message #29

    t was more simple than that.

    I forgot to set to "AmigaDOS" and had "Arexx" visible in the choice gadget.

    Sorry about wasting your time.

    Joseph

  • Message #28

    basically i think that i changed RUN OWB to RUN OWBLauncher. Reverting to RUN OWB works OK

    If "run owb" works, but "run owblauncher" does not, then this is an issue of OWBLauncher being unable to locate the OWB executable. Most probably OWBLauncher will look for the OWB executable in the current directory and the standard Shell command search path only. When being run by YAM the current directory most probably is YAM's program directory. I suggest to use a script which sets the currect directory to OWB's programm directory (where OWBLauncher should reside, too) and then runs OWBLauncher.

  • Message #27

    So do I get you right? It is working now that you have updated OWB?

    Yes indeed. basically i think that i changed RUN OWB to RUN OWBLauncher. Reverting to RUN OWB works OK

    Well, I can't really answer that. I really have to see which commands you exactly entered and what you expect YAM to perform on that action.

    Basically I do intend to lauch Gui4Cli scripts (eg when reading a mail). These would be launched as RUN guis:gui Myscript.gc %sender Since CLI commands like 'RUN echo "hello"' and 'RUN info' failed i did not push the idea. I will do a real try and let you know the results.

    Thanks for your help and programming efforts

    Joseph

  • Message #26

    Hi, I am well aware of the FAQ directive to set up OpenURL I did use this however in YAM2.5 RUN sys:utilities/OWB3.22/OWB %p and that worked OK.

    I thought i did lose this possibility in 2.6 , but it seems that it may be due to a non YAM issue ( i downloaded new versions of OWB and changed the command, i don't know anymore how, but the previous command works well with YAM2.6 too.

    So do I get you right? It is working now that you have updated OWB?

    I tested however commands like RUN echo "hello" and RUN info both of which fail. Maybe the question is why some CLI commands work and others not. Thanks for responding

    Well, I can't really answer that. I really have to see which commands you exactly entered and what you expect YAM to perform on that action.

  • Message #25

    Hi, I am well aware of the FAQ directive to set up OpenURL I did use this however in YAM2.5 RUN sys:utilities/OWB3.22/OWB %p and that worked OK.

    I thought i did lose this possibility in 2.6 , but it seems that it may be due to a non YAM issue ( i downloaded new versions of OWB and changed the command, i don't know anymore how, but the previous command works well with YAM2.6 too. I tested however commands like RUN echo "hello" and RUN info both of which fail. Maybe the question is why some CLI commands work and others not. Thanks for responding

  • Message #24

    Can you describe the ARexx issue a bit more detailed? I can perfectly specify a script which will be invoked when I double click a URL.

    think what he is trying to say is that non-ARexx scripts are not working because he has specified "Run 'MyBrowser %p'" as the doubleclicking action for clicking on an URL. However, it is also unclear to me why this should not work. In addition, if he has installed openurl he does normally also not need to specify that manual action as OpenURL would handle that all for him. So please see the following FAQ entry for more information on how to setup YAM for proper OpenURL support:

    http://yam.ch/wiki/FAQ/Using%20YAM#DoubleclickinganURLdoesntseemtopopupmyfavouritewebbrowser

  • Message #23

    The "disabled move button" issue will be fixed in the next nightly build.

    Can you describe the ARexx issue a bit more detailed? I can perfectly specify a script which will be invoked when I double click a URL.

Tree View Flat View (newer first) Flat View (older first)

Attachments

No attachments created.