YAM - Yet Another Mailer (#2) - Adding filters (#11) - Message List

Adding filters
 solved

Since I bought a Mac I've been getting some emails from Apple. So I created a folder "Apple" and went to set up a filter:

Clicked the new filter button, called the filter "Apple" Set the filter to check "From:" and entered "apple.com" and "IN", case sensitivity turned off. Set the action to "Move to folder Apple". Click Save button for config.

How do I save the filter ? When I go back to the config it is missing. If I try the filter immediately after saving config nothing happens - I'm assuming that it was never entered.

This is on YAM 2.6 on MorphOS.

Tree View Flat View (newer first) Flat View (older first)
  • Message #30

    This issue is known already and existed in YAM 2.5 already. In fact it is more than 3 years old by now.

    If you start with an empty filter list and add your first filter the list will not be saved because the former empty list and now non-empty list are regarded as being the same, which of course is wrong. The same happens if you delete all your configured filters and try to save an empty filter list. What always works without problems is adding/removing filters to/from a non-empty filter list. YAM does some checks to avoid having to save unchanged configurations, even if one pressed the "Save" button.

    The solution to this issue is to do any other change to YAM's configuration (i.e. (un)check the "Check birthdays" option on the Startup/Quit page) and thus force it to save the configuration because of this additional change. After that you can reset that additional option back to its former state and continue to add/remove filters as you like.

  • Message #31

    OK. I tried it and I can save filters now.

    Thanks

Tree View Flat View (newer first) Flat View (older first)

Attachments

No attachments created.