YAM - Yet Another Mailer (#2) - MCC TheBar 21.5 on YAM ? (#22) - Message List

MCC TheBar 21.5 on YAM ?
 solved

I can't open the YAM 2.5 and 2.6 Dev on Amikit, YAM ask me to install TheBar 21.5, I have in my system the latest TheBar 26.1 but doesn't work at all with YAM so I try also the old 21.4 from ZeroHero site but with no luck :roll:

Where I can found 21.5 ?

Tree View Flat View (newer first) Flat View (older first)
  • Message #92

    You are right Thore, but in this case in not completely my fault, as you maybe know AmiKit comes with lot of softwares and addons, so sometimes isn't easy to check and verify all things, YAM and IBrowse (but AmiGift in the past too) for example give some strange blank window at the closure of the program, the cause is (maybe) an erroneous datatype installed by default ...

    The AmiGift's author's solve this little issue in the latest (non pubblic) beta with some workarounds !

    Aniway thanks for the help, much apprecied 8)

  • Message #91

    Nice to hear your problem is solved.

    But adding the suggested workarounds is impossible. Neither YAM nor any other application knows from where libraries are loaded and (and this is far more important) if there might exist further - maybe newer - copies of the same libraries/devices/classes/whatever.

    It is the repsonsibility of the user to keep his system tidy and to install shared stuff like libraries and classes in the standard paths only. If one installs these things in custom paths it is his own fault if some software breaks because of this.

  • Message #90

    I search for all TheBar/TheButton files using the Windows search engine and I found them on AmRSS, Strang? and in another MUI folder on AmiKit, so I delete all of them them and now YAM works ok !

    So I solve this problem too, but it was a very strange problem ...

    Is it possible to add some checks that alert the user about similar issues ?

  • Message #89

    Sorry, still no debug output from TheBar.mcc.

    Just to be sure, please search for any occurence of TheBar#?.mc? and TheButton.mcc on your harddisk, delete these, copy the binaries I sent you to MUI:Libs/mui and reboot.

    If you have Sashimi running then even running the demo programs with TheBar should output some debug messages. Otherwise there is still another version active which is used instead of the debug binaries.

  • Message #88

    Ok here a new one:

    Sashimi installed ([Ctrl]+C or "Break 1" to remove)
    ENV:TheBar.mcc.debug to "@all all"
    ** YAM 2.6-dev [OS3/m68k] build: 20080605 startup **********************
    Exec version: v45.0
    no 'yamdebug' variable found
    set debug classes/flags (env:yamdebug): 00000076/00000003
    ** Normal processing follows ***************************************
    YAM.c:231:InitLib: library intuition.library v40.85 successfully opened.
    YAM.c:231:InitLib: library icon.library v52.543 successfully opened.
    YAM.c:231:InitLib: library utility.library v40.1 successfully opened.
    YAM.c:231:InitLib: library diskfont.library v46.0 successfully opened.
    extrasrc/NewReadArgs.c:464:ReadArgs() okay
    YAM.c:2458:ProgDir.: 'AmiKit:Internet/YAM 2.6/YAM 2.5'
    YAM.c:2459:ProgName: 'YAM.debug'
    YAM.c:624:Didn't find any AutoDST facility active!
    YAM.c:231:InitLib: library locale.library v44.6 successfully opened.
    Locale.c:2917:successfully opened YAM.catalog version 6
    YAM.c:231:InitLib: library graphics.library v45.1 successfully opened.
    YAM.c:231:InitLib: library layers.library v40.1 successfully opened.
    YAM.c:231:InitLib: library workbench.library v45.102 successfully opened.
    YAM.c:231:InitLib: library keymap.library v40.4 successfully opened.
    YAM.c:231:InitLib: library iffparse.library v40.1 successfully opened.
    YAM.c:231:InitLib: library rexxsyslib.library v44.1 successfully opened.
    YAM.c:231:InitLib: library datatypes.library v44.47 successfully opened.
    YAM.c:231:InitLib: library cybergraphics.library v45.0 successfully opened.
    YAM.c:231:InitLib: library muimaster.library v19.35 successfully opened.
    YAM.c:231:InitLib: library openurl.library v7.4 successfully opened.
    YAM.c:231:InitLib: library codesets.library v6.5 successfully opened.
    YAM.c:235:InitLib: can't open library expat.library with minimum version v2.0
    YAM.c:231:InitLib: library amisslmaster.library v3.6 successfully opened.
    YAM.c:1811:successfully opened AmiSSL library.
    YAM.c:295:name = 0x11CE3B58 "TheBar.mcc"
    YAM.c:1128:cleaning up in 'yam_exitfunc'...
    YAM.c:818:freeing spam filter module...
    YAM.c:821:freeing config module...
    YAM.c:831:freeing addressbook entries...
    YAM.c:835:freeing readmailData...
    YAM.c:854:freeing writemailData...
    YAM.c:873:freeing tcp/ip stuff...
    YAM.c:893:finalizing indexes and closing main window...
    YAM.c:916:freeing addressbook module...
    YAM.c:920:freeing main window module...
    YAM.c:924:freeing FileReqCache structures...
    AppIcon.c:75:freeing AppIcon...
    AppIcon.c:79:freeing AppPort...
    YAM.c:938:freeing write window file notify port...
    YAM.c:942:freeing Arexx port...
    YAM.c:946:freeing timer resources...
    YAM.c:950:stoping ADSTnotify...
    YAM.c:954:freeing newmailsound object...
    YAM.c:958:freeing hideIcon...
    YAM.c:962:deleting zombie files...
    YAM.c:982:freeing toolbar cache...
    YAM.c:985:freeing config...
    YAM.c:991:freeing private codesets list...
    YAM.c:1001:cleaning up XPK stuff...
    YAM.c:1006:cleaning up XAD stuff...
    YAM.c:1009:freeing main application object...
    YAM.c:1013:unloading/freeing theme images...
    YAM.c:1016:freeing image cache...
    YAM.c:1019:freeing internal MUI classes...
    YAM.c:1022:deleting semaphore...
    YAM.c:1025:cleaning up thread system...
    YAM.c:1029:cleaning up AmiSSL stuff...
    YAM.c:1041:closing all opened libraries...
    YAM.c:1059:closing catalog...
    extrasrc/NewReadArgs.c:84:FreeArgs(rdargs->FreeArgs)
    extrasrc/NewReadArgs.c:91:FreeDosObject(DOS_RDARGS, rdargs->RDArgs)
    extrasrc/NewReadArgs.c:113:memory freed
    ** Cleaned up debugging ********************************************
    Sashimi removed.
    
  • Message #87

    Well, if I said I need a debug log of TheBar.mcc before and you didn't provide one, what do you guess? :)

    Of course I still need a log. Without that there will be no progress on this issue.

  • Message #86

    Mmm I copy the TheBar debug class on:

    AmiKit\Utilities\EXPANSION\MUI\Libs\mui

    And reboot, but maybe. .. do you need another Sashimi log ?

  • Message #85

    Ok. I put TheBar Debug class into the MUI directory and lanch YAM debug, here the output:

    Is that ok or this is only the YAM Debug output report, don't understand too much ...

    You must have misinstalled the classes, because you should definitely get some output from TheBar.mcc. Did you copy them to MUI:Libs/mui? And did you reboot or have you called "avail flush" to make sure that there are no old versions still in memory?

  • Message #84

    Ok. I put TheBar Debug class into the MUI directory and lanch YAM debug, here the output:

    Is that ok or this is only the YAM Debug output report, don't understand too much ...

    Sashimi installed ([Ctrl]+C or "Break 1" to remove)
    ENV:TheBar.mcc.debug to "@all all"
    ** YAM 2.6-dev [OS3/m68k] build: 20080605 startup **********************
    Exec version: v45.0
    no 'yamdebug' variable found
    set debug classes/flags (env:yamdebug): 00000076/00000003
    ** Normal processing follows ***************************************
    YAM.c:231:InitLib: library intuition.library v40.85 successfully opened.
    YAM.c:231:InitLib: library icon.library v52.543 successfully opened.
    YAM.c:231:InitLib: library utility.library v40.1 successfully opened.
    YAM.c:231:InitLib: library diskfont.library v46.0 successfully opened.
    extrasrc/NewReadArgs.c:464:ReadArgs() okay
    YAM.c:2458:ProgDir.: 'AmiKit:Internet/YAM 2.6/YAM 2.5'
    YAM.c:2459:ProgName: 'YAM.debug'
    YAM.c:624:Didn't find any AutoDST facility active!
    YAM.c:231:InitLib: library locale.library v44.6 successfully opened.
    Locale.c:2917:successfully opened YAM.catalog version 6
    YAM.c:231:InitLib: library graphics.library v45.1 successfully opened.
    YAM.c:231:InitLib: library layers.library v40.1 successfully opened.
    YAM.c:231:InitLib: library workbench.library v45.102 successfully opened.
    YAM.c:231:InitLib: library keymap.library v40.4 successfully opened.
    YAM.c:231:InitLib: library iffparse.library v40.1 successfully opened.
    YAM.c:231:InitLib: library rexxsyslib.library v44.1 successfully opened.
    YAM.c:231:InitLib: library datatypes.library v44.47 successfully opened.
    YAM.c:231:InitLib: library cybergraphics.library v45.0 successfully opened.
    YAM.c:231:InitLib: library muimaster.library v19.35 successfully opened.
    YAM.c:231:InitLib: library openurl.library v7.4 successfully opened.
    YAM.c:231:InitLib: library codesets.library v6.5 successfully opened.
    YAM.c:235:InitLib: can't open library expat.library with minimum version v2.0
    YAM.c:231:InitLib: library amisslmaster.library v3.6 successfully opened.
    YAM.c:1811:successfully opened AmiSSL library.
    YAM.c:295:name = 0x11B7F170 "TheBar.mcc"
    YAM.c:1128:cleaning up in 'yam_exitfunc'...
    YAM.c:818:freeing spam filter module...
    YAM.c:821:freeing config module...
    YAM.c:831:freeing addressbook entries...
    YAM.c:835:freeing readmailData...
    YAM.c:854:freeing writemailData...
    YAM.c:873:freeing tcp/ip stuff...
    YAM.c:893:finalizing indexes and closing main window...
    YAM.c:916:freeing addressbook module...
    YAM.c:920:freeing main window module...
    YAM.c:924:freeing FileReqCache structures...
    AppIcon.c:75:freeing AppIcon...
    AppIcon.c:79:freeing AppPort...
    YAM.c:938:freeing write window file notify port...
    YAM.c:942:freeing Arexx port...
    YAM.c:946:freeing timer resources...
    YAM.c:950:stoping ADSTnotify...
    YAM.c:954:freeing newmailsound object...
    YAM.c:958:freeing hideIcon...
    YAM.c:962:deleting zombie files...
    YAM.c:982:freeing toolbar cache...
    YAM.c:985:freeing config...
    YAM.c:991:freeing private codesets list...
    YAM.c:1001:cleaning up XPK stuff...
    YAM.c:1006:cleaning up XAD stuff...
    YAM.c:1009:freeing main application object...
    YAM.c:1013:unloading/freeing theme images...
    YAM.c:1016:freeing image cache...
    YAM.c:1019:freeing internal MUI classes...
    YAM.c:1022:deleting semaphore...
    YAM.c:1025:cleaning up thread system...
    YAM.c:1029:cleaning up AmiSSL stuff...
    YAM.c:1041:closing all opened libraries...
    YAM.c:1059:closing catalog...
    extrasrc/NewReadArgs.c:84:FreeArgs(rdargs->FreeArgs)
    extrasrc/NewReadArgs.c:91:FreeDosObject(DOS_RDARGS, rdargs->RDArgs)
    extrasrc/NewReadArgs.c:113:memory freed
    ** Cleaned up debugging ********************************************
    Sashimi removed.
    
  • Message #83

    Please give me your private EMail address.

    My mail address is in your mailer, i'm the author of the italian translation of YAM :-)

    I will then send over a debug build of TheBar.mcc to you which you can use to generate a debug log after having set ENV:TheBar.mcc.debug to "@all all". You need the OS3 build, is that correct?

    Thanks a lot Thore, much apprecied, yes I need a 68k version to test, I use Amiga Forever and AmiKit via emulation

  • Message #82

    Yes, to be sure I delete the YAM's folder completely and replace it with a new one (2.5 final) without the MUI directory, but I have the same problem with TheBar, using another computer with AmiKit I have no problem at all, so maybe I manage somethings here and there in my system configuration that cause this problem.

    Please give me your private EMail address. I will then send over a debug build of TheBar.mcc to you which you can use to generate a debug log after having set ENV:TheBar.mcc.debug to "@all all". You need the OS3 build, is that correct?

    P.S. What happen with the italian translation, it seems removed from the latest nighly builds ...

    The translation was broken due to duplicate identifiers. This has been fixed in the meantime.

  • Message #81

    BTW: Are you sure you don't have any YAM:mcc directory or YAM:mui directory with locally installed .mcc files? All .mcc should ONLY be put into MUI:Libs/mui and nowhere else.

    Yes, to be sure I delete the YAM's folder completely and replace it with a new one (2.5 final) without the MUI directory, but I have the same problem with TheBar, using another computer with AmiKit I have no problem at all, so maybe I manage somethings here and there in my system configuration that cause this problem.

    But the question is what !

    Are there any system (or software) to watch my configuration that can help you to understand where is the problem ?

    Thanks

    P.S. What happen with the italian translation, it seems removed from the latest nighly builds ...

  • Message #80

    The logs don't offer any news. YAM tries to create an object of TheBar.mcc and simply fails to do this. That's why you get that error requester telling you that TheBar.mcc isn't installed at all.

    Sorry, but it seems there is nothing we can do about that. Nobody else has this problem and it is absolutely not reproducable for us.

  • Message #79

    Using Sashimi command (setenv yamdebug @all all) I have also this shell output:

    Sashimi installed ([Ctrl]+C or "Break 1" to remove)
    setenv yamdebug @all all
    ** YAM 2.6-dev [OS3/m68k] build: 20080531 startup **********************
    Exec version: v45.0
    no 'yamdebug' variable found
    set debug classes/flags (env:yamdebug): 00000076/00000003
    ** Normal processing follows ***************************************
    YAM.c:234:InitLib: library intuition.library v40.85 successfully opened.
    YAM.c:234:InitLib: library icon.library v52.543 successfully opened.
    YAM.c:234:InitLib: library utility.library v40.1 successfully opened.
    YAM.c:234:InitLib: library diskfont.library v46.0 successfully opened.
    extrasrc/NewReadArgs.c:464:ReadArgs() okay
    YAM.c:2461:ProgDir.: 'AmiKit:Internet/YAM 2.6'
    YAM.c:2462:ProgName: 'YAM.debug'
    YAM.c:627:Didn't find any AutoDST facility active!
    YAM.c:234:InitLib: library locale.library v44.6 successfully opened.
    Locale.c:2917:successfully opened YAM.catalog version 6
    YAM.c:234:InitLib: library graphics.library v45.1 successfully opened.
    YAM.c:234:InitLib: library layers.library v40.1 successfully opened.
    YAM.c:234:InitLib: library workbench.library v45.102 successfully opened.
    YAM.c:234:InitLib: library keymap.library v40.4 successfully opened.
    YAM.c:234:InitLib: library iffparse.library v40.1 successfully opened.
    YAM.c:234:InitLib: library rexxsyslib.library v44.1 successfully opened.
    YAM.c:234:InitLib: library datatypes.library v44.47 successfully opened.
    YAM.c:234:InitLib: library cybergraphics.library v45.0 successfully opened.
    YAM.c:234:InitLib: library muimaster.library v19.35 successfully opened.
    YAM.c:234:InitLib: library openurl.library v7.4 successfully opened.
    YAM.c:234:InitLib: library codesets.library v6.5 successfully opened.
    YAM.c:238:InitLib: can`t open library expat.library with minimum version v2.0
    YAM.c:234:InitLib: library amisslmaster.library v3.6 successfully opened.
    YAM.c:1814:successfully opened AmiSSL library.
    YAM.c:298:name = 0x11EE6098 "TheBar.mcc"
    YAM.c:1131:cleaning up in 'yam_exitfunc'...
    YAM.c:821:freeing spam filter module...
    YAM.c:824:freeing config module...
    YAM.c:834:freeing addressbook entries...
    YAM.c:838:freeing readmailData...
    YAM.c:857:freeing writemailData...
    YAM.c:876:freeing tcp/ip stuff...
    YAM.c:896:finalizing indexes and closing main window...
    YAM.c:919:freeing addressbook module...
    YAM.c:923:freeing main window module...
    YAM.c:927:freeing FileReqCache structures...
    AppIcon.c:75:freeing AppIcon...
    AppIcon.c:79:freeing AppPort...a
    AppIcon.c:79:freeing AppPort...
    YAM.c:941:freeing write window file notify port...
    YAM.c:945:freeing Arexx port...
    YAM.c:949:freeing timer resources...
    YAM.c:953:stoping ADSTnotify...
    YAM.c:957:freeing newmailsound object...
    YAM.c:961:freeing hideIcon...
    YAM.c:965:deleting zombie files...
    YAM.c:985:freeing toolbar cache...
    YAM.c:988:freeing config...
    YAM.c:994:freeing private codesets list...
    YAM.c:1004:cleaning up XPK stuff...
    YAM.c:1009:cleaning up XAD stuff...
    YAM.c:1012:freeing main application object...
    YAM.c:1016:unloading/freeing theme images...
    YAM.c:1019:freeing image cache...
    YAM.c:1022:freeing internal MUI classes...
    YAM.c:1025:deleting semaphore...
    YAM.c:1028:cleaning up thread system...
    YAM.c:1032:cleaning up AmiSSL stuff...
    YAM.c:1044:closing all opened libraries...
    YAM.c:1062:closing catalog...
    extrasrc/NewReadArgs.c:84:FreeArgs(rdargs->FreeArgs)
    extrasrc/NewReadArgs.c:91:FreeDosObject(DOS_RDARGS, rdargs->RDArgs)
    extrasrc/NewReadArgs.c:113:memory freed
    ** Cleaned up debugging ********************************************
    
  • Message #78

    Here the debug version using Sashimi output:

    Sashimi installed ([Ctrl]+C or "Break 1" to remove)
    ** YAM 2.6-dev [OS3/m68k] build: 20080531 startup **********************
    Exec version: v45.0
    no 'yamdebug' variable found
    set debug classes/flags (env:yamdebug): 00000076/00000003
    ** Normal processing follows ***************************************
    YAM.c:234:InitLib: library intuition.library v40.85 successfully opened.
    YAM.c:234:InitLib: library icon.library v52.543 successfully opened.
    YAM.c:234:InitLib: library utility.library v40.1 successfully opened.
    YAM.c:234:InitLib: library diskfont.library v46.0 successfully opened.
    extrasrc/NewReadArgs.c:464:ReadArgs() okay
    YAM.c:2461:ProgDir.: 'AmiKit:Internet/YAM 2.6'
    YAM.c:2462:ProgName: 'YAM.debug'
    YAM.c:627:Didn't find any AutoDST facility active!
    YAM.c:234:InitLib: library locale.library v44.6 successfully opened.
    Locale.c:2917:successfully opened YAM.catalog version 6
    YAM.c:234:InitLib: library graphics.library v45.1 successfully opened.
    YAM.c:234:InitLib: library layers.library v40.1 successfully opened.
    YAM.c:234:InitLib: library workbench.library v45.102 successfully opened.
    YAM.c:234:InitLib: library keymap.library v40.4 successfully opened.
    YAM.c:234:InitLib: library iffparse.library v40.1 successfully opened.
    YAM.c:234:InitLib: library rexxsyslib.library v44.1 successfully opened.
    YAM.c:234:InitLib: library datatypes.library v44.47 successfully opened.
    YAM.c:234:InitLib: library cybergraphics.library v45.0 successfully opened.
    YAM.c:234:InitLib: library muimaster.library v19.35 successfully opened.
    YAM.c:234:InitLib: library openurl.library v7.4 successfully opened.
    YAM.c:234:InitLib: library codesets.library v6.5 successfully opened.
    YAM.c:238:InitLib: can`t open library expat.library with minimum version v2.0
    YAM.c:234:InitLib: library amisslmaster.library v3.6 successfully opened.
    YAM.c:1814:successfully opened AmiSSL library..
    YAM.c:298:name = 0x11EE6228 "TheBar.mcc"
    Sashimi removed.
    
  • Message #77

    Yes they work ... I have this problem only using YAM (both 2.5 and 2.6 Dev)

    Maybe would help to bumped minimum required version of TheBar to v26.1 ?

    Why should it work when we bump the minimum required version of 26.1? A better solution to find the problem would be if you could use a debug version of YAM and catch some debug information for us so that we can investigate and see why it fails to load TheBar 21.5 for you.

    BTW: Are you sure you don't have any YAM:mcc directory or YAM:mui directory with locally installed .mcc files? All .mcc should ONLY be put into MUI:Libs/mui and nowhere else.

  • Message #76

    Yes they work ... I have this problem only using YAM (both 2.5 and 2.6 Dev)

    Maybe would help to bumped minimum required version of TheBar to v26.1 ?

  • Message #75

    Do the demos supplied with TheBar work?

  • Message #74

    Done:

    TheBar.mcc 21.5 (020) (21-Dic-2007)
    Copyright (c) 2005-2007 TheBar Open Source Team
    
  • Message #73

    If YAM still complains then you didn't install the class files correctly.

    Which output do you get if you do a "version MUI:Libs/mui/TheBar.mcc full file" in a shell?

  • Message #72

    Thanks, just downloading and installing the old 21.5, but YAM don't work again !

    It ask me to install MCC TheBar 21.5 at startup :shock:

    Here the error:

    Couldn't open required MUI custom class TheBar 21.5
    Please visit sourceforge
    download the most recent version and make
    sure you have it correctly installed.
    

    Don't know why I have this problem, AFAIK older nighly works nice on AmiKit, today I try the latest nighy build with AmigaForever 6.0 + TheBar 26.1 and all goes well :roll:

    Maybe AmiKit fails to load something ?

    I try almost all TheBar release but with no luck ...

  • Message #71

    I can't open the YAM 2.5 and 2.6 Dev on Amikit, YAM ask me to install TheBar 21.5, I have in my system the latest TheBar 26.1 but doesn't work at all with YAM so I try also the old 21.4 from ZeroHero site but with no luck :roll:

    Where I can found 21.5 ?

    As usual you will find all different update versions of TheBar and the other .mcc projects on their respective sourceforge.net project pages. For all the released lha archives see here:

    http://sourceforge.net/projects/thebar/files/

    However, please note that YAM should work fine with 26.1 also. That's the version we are all using here and which will be the new default/required version at some point in the future. So please be more precise and tell us what exactly does not work with 26.1 so that we can investigate and fix it in 26.2.

Tree View Flat View (newer first) Flat View (older first)

Attachments

No attachments created.