YAM - Yet Another Mailer (#2) - YAM2.8 sent msg body as base64 (#95) - Message List

YAM2.8 sent msg body as base64
 unsolved

If I create a simple test message with '123' as body YAM28dev always encodes it as base64

Email exported from YAM28dev:

From jabierdlr@gmail.com Tue Oct 02 17:03:00 2012
Status: RO
X-Status: R
X-YAM-Options: signature=03f427be,identity=53405eae,security=none
From: Javier de las Rivas <jabierdlr@gmail.com>
To: Javier de las Rivas <javierdlr@euskalnet.net>
Date: Tue, 02 Oct 2012 19:03:00 +0200
Message-ID: <415efb642.5f8d1181@smtp.gmail.com>
User-Agent: YAM/2.8-dev (AmigaOS4; PPC; rv:20120922r6281)
Subject: 456
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: base64
NDU2DQoNCi0tIA0KaHR0cDovL2phYmlydWxvLnNpdGU5MC5jb20vamF2aWVyZGxyDQpBT25l
LVhFL0FPUzQuMS9QUEM3NDU1LTgwMC81MTJNQi9SYWRlb245MjAwL0hERDgwR0IvRFZEL0RW
RLFSVyAgOi1Q

text is "only" '456' (and my signature), so why not leave it as ASCII/plain text or I'm a doing something wrong?

errm, seems my signature: http://jabirulo.site90.com/javierdlr .. Is treated as spam ¿:-/ so that't why I get those problems. OUPS sorry.

TIA

Tree View Flat View (newer first) Flat View (older first)
  • Message #361

    If I create a simple test message with '123' as body YAM28dev always encodes it as base64

    [...]

    errm, seems my signature: http://jabirulo.site90.com/javierdlr .. Is treated as spam ¿:-/ so that't why I get those problems. OUPS sorry.

    So is there actually a problem or not?

    If you think there is a problem then please open a bug ticket in YAM's bugtracker and add a "mime" log created with the debug version of YAM 2.8-dev. Refer to the FAQ for details.

    I just tried to reproduce this issue and for me YAM always uses plain 7 bit encoding.

  • Message #362

    Enter your message here...

    Just noticed if I set 'SERVER ALLOWS 8 BIT' (TCP/IP->SMTP server) messages are sent as plain, files, but if I have such option disabled it encodes the body message as base64. Sorry didn't know that. But if you still need the debug output I can do it if you want.

    Sorry and THX

  • Message #363

    Just noticed if I set 'SERVER ALLOWS 8 BIT' (TCP/IP->SMTP server) messages are sent as plain, files, but if I have such option disabled it encodes the body message as base64. Sorry didn't know that. But if you still need the debug output I can do it if you want.

    No need for a log. I just checked the source. YAM tries to be as smart as possible. If 8bit encoding is not permitted by the SMTP server you will be notified about that automatically.

  • Message #364

    OK THX

Tree View Flat View (newer first) Flat View (older first)

Attachments

No attachments created.