YAM Development (#4) - Draft message not deleted after sent (#96) - Message List

Draft message not deleted after sent
 unsolved

When wrting a message a DRAFT is created in such folder (YMA2.8dev), but after message is sent it still full/partial message in DRAFT folder. Maybe is it deleted after a few minutes don't know, but IMHO it should be deleted after message is sent (successful or not) Need debug output?

Tree View Flat View (newer first) Flat View (older first)
  • Message #365

    When wrting a message a DRAFT is created in such folder (YMA2.8dev), but after message is sent it still full/partial message in DRAFT folder. Maybe is it deleted after a few minutes don't know, but IMHO it should be deleted after message is sent (successful or not) Need debug output?

    If you think it is a bug then there is nothing to discuss, just open a new ticket in the bugtracker and explain as detailed as possible under which conditions the draft mail is not deleted (i.e. write save interval time, etc). I tested this feature very often and for me the draft mail was always correctly deleted. However, in the beginning right after implementing the draft feature it could happen that the draft mail was not deleted, but this has been fixed a few weeks ago.

    Please keep in mind that the forum is meant to discuss certain things, like how things can be accomplished, but bugs belong to the bug tracker. Don't be affraid to report bugs, even if they eventually turn out to be caused by misinterpretation or wrong usage. Not reporting a possible bug at all is worse than reporting a false bug.

    Finally if an issue happens with the development version please always state exactly which version you are referring to (i.e. date, SVN revision). Just telling about "the latest night build" might be enough for the moment, but not for later reference.

  • Message #366

    Replying to myself:

    I tested this feature very often and for me the draft mail was always correctly deleted.

    It seems I didn't test this stuff intensively enough and could reproduce this issue immediately after writing my previous reply. The next nightly build will fix this.

    But please report such issues in YAM's bug tracker right from the start.

  • Message #367

    OK, maybe it was some fault of mine, 'cos now I've written a couple of message and they are deleted after send from DRAFT folder ¿:-/ Will try to be alert, and make some steps to reproduce such strange behaviour or am I getting old and see thing that don't exists!!! :-)

    TIA

Tree View Flat View (newer first) Flat View (older first)

Attachments

No attachments created.