close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 4 years ago

#14 closed bug (fixed)

Keyboard control doesn't highlight correctly

Reported by: colinward Owned by: tboeckel
Priority: normal Milestone: YAM 2.6p1
Component: user interface Version: 2.6
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

A while ago I reported a problem here with keyboard control not working
properly and was advised to update to the latest YAM. I did this and it
seemed to be fixed, but I just realised that it's not. It's easy to
reproduce.

1) Select a message in the list of messages in the right pane.
2) Press shift-tab 4 times to select a foler in the list of folders in the
left pane.
3) Press the up or down arrow key.

You will see the the greyed out highlight in the message pane moves, not
the blue highlight in the folder pane.

This is with the latest YAM nightly build.


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=2893895&group_id=13560&atid=113560

Attachments (0)

Change History (10)

comment:1 Changed 4 years ago by damato

  • Priority changed from major to undecided
  • Severity set to major

comment:2 Changed 4 years ago by damato

  • Component changed from nightly build to undefined

comment:3 Changed 4 years ago by damato

  • Cc yamos-svn@… removed

comment:4 Changed 4 years ago by damato

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.7
  • Priority changed from undecided to normal
  • Severity changed from major to minor
  • Status changed from new to accepted

Indeed, I am able to reproduce that. It seems we have to invest some more time in checking why with changing the focus via the keyboard doesn't end up in a changed keyboard focus.

comment:5 Changed 4 years ago by tboeckel

  • Owner changed from somebody to tboeckel
  • Status changed from accepted to assigned

comment:6 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4815]) * YAM_MA.c, mui/MainWindow.c, mui/MainMailListGroup.c: the "active object on

click" feature of NList must operate on listview objects instead of the em-
bedded list objects. Thus we have to distinguish between these two in lots
of places. Together with the latest modificiations to NList itself this
closes #14. The bug is already fixed without the NList modifications, but
there will still be the annoying active borders because of a limitation of
the current NList release.

comment:7 Changed 4 years ago by damato

  • Description modified (diff)
  • Milestone changed from YAM 2.7 to YAM 2.6p1
  • Resolution fixed deleted
  • Status changed from closed to reopened

reopened due to upcoming merge on 2.6p1 branch.

comment:8 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4988]) * tools/mkrelease.sh: copied over the mkrelease.sh script from the 2.7 branch.

This fixes #14.

comment:9 Changed 4 years ago by tboeckel

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopened because of accidentally wrong closed ticket.

comment:10 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [5002]) * YAM_MA.c, mui/MainWindow.c, mui/MainMailListGroup.c: the "active object on

click" feature of NList must operate on listview objects instead of the em-
bedded list objects. Thus we have to distinguish between these two in lots
of places. Together with the latest modificiations to NList itself this
closes #14.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Colin Ward(Reporter)
  • Thore Böckelmann(Owner, Participant)