close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 5 years ago

#15 closed bug

YAM crashing when dragging mail to another folder...

Reported by: padrino Owned by: somebody
Priority: normal Milestone:
Component: user interface Version: 2.6
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Sound so familar, somehow... I get crashes (3 in one week) when moving a mail from incomming to another folder by drag and drop. Find GrimReaper Log attached.


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=2914337&group_id=13560&atid=113560

Attachments (4)

Crashlog_YAM_2009-12-14_19-55-06.txt (8.2 KB) - added by damato 5 years ago.
crash on drag and drop - Moved from SF. Original author: padrino
Crashlog_YAM_2010-01-08_12-08-01.txt (32.3 KB) - added by damato 5 years ago.
another reaper - Moved from SF. Original author: padrino
dont_move_me.msg (6.8 KB) - added by padrino 5 years ago.
GR on the move
Crashlog_YAM_2010-03-09_16-08-51.txt (32.3 KB) - added by padrino 5 years ago.
latest reaper

Download all attachments as: .zip

Change History (24)

Changed 5 years ago by damato

crash on drag and drop - Moved from SF. Original author: padrino

comment:1 Changed 5 years ago by damato

Can you give some more information about the crashes, please? Do you have a separate read window opened or are you using the embedded read pane? Even if it should make no difference at all, does the crash happen for other folders as well or just for the Incoming folder?


Moved from SF. Original poster: thboeckel

comment:2 Changed 5 years ago by damato

I am using external read windows. As my habbit is only to drag from inbox to a special box I cannot tell about others. And as said, this is random, but repetitive... Could be, that it happens, when the d&d'ed mail is open at that time. Not sure though. Sorry.


Moved from SF. Original poster: padrino

comment:3 Changed 5 years ago by damato

Ok,

today it happened again. External readwin displaying message, moving it to another folder. As usual the same folder, my favourite operation ;) I will attach the log, though it is probably useless. BTW, it's no crash, but a GR YAM does recover from. Are there any debug things I can use and still be able to use YAM nicely? As you can see, this really happens very rarely.

Using YAM 2.6-dev [OS4/PPC] (28.12.2009) Copyright (C) 2000-2009 YAM Open Source Team at the moment...


Moved from SF. Original poster: padrino

Changed 5 years ago by damato

another reaper - Moved from SF. Original author: padrino

comment:4 Changed 5 years ago by damato

Can you please provide such a crashing example mail? Maybe it is not a general bug in YAM but very specific to certain mails.


Moved from SF. Original poster: thboeckel

comment:5 in reply to: ↑ description Changed 5 years ago by padrino

If/when it happens again I will provide the message.

comment:6 Changed 5 years ago by damato

  • Priority changed from major to undecided
  • Severity set to major

comment:7 Changed 5 years ago by damato

  • Reporter changed from padrino@… to padrino

comment:8 Changed 5 years ago by damato

  • Component changed from nightly build to undefined

comment:9 Changed 5 years ago by damato

  • Cc yamos-svn@… removed

comment:10 Changed 5 years ago by damato

  • Component changed from undefined to user interface
  • Priority changed from undecided to normal
  • Status changed from new to pending

changing status to pending to see if the issue comes up again or not.

comment:11 Changed 5 years ago by tboeckel

Could you please provide an example mail which caused a crash for you? The more I think about it the more I come to the conclusion that this is not a general bug in YAM's way to handle the data but depends on certain mails and their structure.

comment:12 Changed 5 years ago by padrino

  • Status changed from pending to new

Where is my comment that it did not happen recently anymore?!

So I have no mail here, to show.

If it happens again, I can provide that mail.

I could provide some mails where I think it happend, but I am not perfectly sure.

comment:13 Changed 5 years ago by tboeckel

Just try yourself with the mails in suspect if you can make YAM crash. If the crash happens then please attach one or two of these mails to this report. Otherwise we'll have to wait until it happens again. Maybe my assumption is simply wrong and the bug is fixed already by pure luck.

comment:14 Changed 5 years ago by padrino

Thanks for the info/idea. ;)
I am amazed how easily I could produce the grim reaper.
I'll attach the mail right away.

May theory is this it might be a YAM updating index while moving a mail timing thing, though I don't know if it this possible...

As the GR happends after dragging less then 10 mails (one after another, quite fast), I am confident, that I could reproduce it quite easily.

So if you want me to check it with debug YAM and special debug-settings, just tell and I will give it a try.

Changed 5 years ago by padrino

GR on the move

Changed 5 years ago by padrino

latest reaper

comment:15 Changed 5 years ago by tboeckel

So far I couldn't make YAM/OS3 crash with this mail, no matter how often I move it from one folder to another one with the read window being open. It seems only OS4 is affected right now.

Did you receive the mail exactly like this or did you modify it before you added it here? I am wondering, because "m@…" is definitely no valid email address.

Just to be sure, please create a MIME+MAIL log with either the current or the next nightly build.

comment:16 Changed 5 years ago by padrino

Yes, I altered the adresses for privacy reasons.

comment:17 Changed 5 years ago by tboeckel

I don't know if I am too dumb or if the issue simply doesn't happen for me. No matter how often I drag the mail from one folder to another I cannot make YAM crash, neither on OS3 nor on OS4. I tried to reproduce the issue as follows:

  1. import the attached mail into an arbitrary folder
  2. open the mail into a separate read window
  3. drag the mail from the main window's mail list to a different folder, the read window will be closed by this
  4. start again at point 2.

Anything different from your way to make YAM crash?

comment:18 Changed 5 years ago by padrino

I can't make it crash atm either. I tried in normal use and also in heavy use with debug. Though a few days/versions ago it seemed easy, at least once. ;)

Your actions seem correct though.

I'll see if this will happen here, in every day use duing the next days/week. If not, maybe it's really gone by accident. Let's see :)

comment:19 Changed 5 years ago by damato

  • Status changed from new to pending

Ok thanks Mario for the information. I will flag that ticket as 'pending' so that after 14 days the tracker will automatically close it. Just reopen it if the problem reappears. Just check your "My Reports" link at the top right corner of this website.

comment:20 Changed 5 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mario Cattaneo(Reporter, Participant)