close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#154 closed bug (fixed)

Exporting messages with no file name crashes

Reported by: hypex Owned by:
Priority: undecided Milestone: YAM 2.6p1
Component: mail import/export Version: 2.6
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

Hello again.

This is very wasy to reproduce. Select some message(s). Export it. Leave the file name field blank. Tell it to overwrite. Boom!

Crashlog supplied.

Crash log for task "YAM"
Generated by GrimReaper 53.2
Crash occured in module YAM at address 0x7F8D49B0
Type of crash: DSI (Data Storage Interrupt) exception

Register dump:
GPR (General Purpose Registers):

0: 00000073 5F017870 01842D00 5C57F404 00000000 7F8D496C 00000000 00000005
8: 591741FC 591741FE 00000004 5FCDE6C0 00000824 5C585688 5F01897C 5F018978

16: 5C580000 5F0178A0 0000000C 00000002 5C580000 5C580000 60462410 5F0178F0
24: 591741EC 00000000 58888938 6FFFF800 01998E54 5C580000 8042F8DC 60462330

FPR (Floating Point Registers, NaN = Not a Number):

0: nan 0.867188 352 152
4: 0 157.8 232.8 152
8: 0 4.5036e+15 4.5036e+15 10

12: 2.92596e-13 0.5 -3.26973e-96 3.78832e-171
16: -1.00064e-38 -3.53046e-74 -2.229e+284 1.34911e-12
20: -2.5495e-26 -1.16627e+285 0.000963684 -7.10917e+210
24: 7.26077e+280 -7.56949e-06 -5.76484e-129 -5.46041e-48
28: 0.00170485 -1.0226e+291 -2.34518e-38 -4.55421e-159

FPSCR (Floating Point Status and Control Register): 0x82024000

SPRs (Special Purpose Registers):

Machine State (msr) : 0x0000F030

Condition (cr) : 0x39005153

Instruction Pointer (ip) : 0x7F8D49B0

Xtended Exception (xer) : 0xA000C978

Count (ctr) : 0x00000000

Link (lr) : 0x7F8D496C

DSI Status (dsisr) : 0x40000000
Data Address (dar) : 0x00000024

680x0 emulated registers:
DATA: 00000000 00000003 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 6041D85C 00000000 00000000 00000000 00000000 00000000 00000000 5F018360
FPU0: 0 0 0 0
FPU4: 0 0 0 0

Symbol info:
Instruction pointer 0x7F8D49B0 belongs to module "YAM" (PowerPC)
Symbol: TR_ConnectPOP + 0x380 in section 1 offset 0x000CE990

Stack trace:

TR_ConnectPOP()+0x380 (section 1 @ 0xce990)
TR_GetMailFromNextPOP()+0x940 (section 1 @ 0xcfb08)
TR_GetMailFromNextPOP()+0xBC8 (section 1 @ 0xcfd90)
MA_PopNow()+0x80 (section 1 @ 0xb654c)
ProcessTimerEvent()+0xA30 (section 1 @ 0x103ff0)
main()+0xDC4 (section 1 @ 0x520c)
native kernel module newlib.library.kmod+0x00001f44
native kernel module newlib.library.kmod+0x00002bd8
native kernel module newlib.library.kmod+0x00002d54
_start()+0x170 (section 1 @ 0x170)
native kernel module dos.library.kmod+0x0001a228
native kernel module kernel+0x0003cd50
native kernel module kernel+0x0003cdd0


PPC disassembly:

7f8d49a8: 3adf00e0 addi r22,r31,224
7f8d49ac: 839b0204 lwz r28,516(r27)

*7f8d49b0: 82440024 lwz r18,36(r4)

7f8d49b4: 48024085 bl 0x7F8F8A38
7f8d49b8: 9061000c stw r3,12(r1)

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [4658]) * YAM_MA.c: when exporting mails the file name returned by the file requester

is now checked to be non-empty. Although I could not reproduce ticket #154
this should fix it and thus closes #154.

comment:2 follow-up: Changed 5 years ago by tboeckel

  • Milestone set to YAM 2.7

Please note that the attached crashlog has absolutely nothing in common with the stated issue. The crashlog points to some code which is executed when downloading mails from a POP3 server.

If the issue still happens then please reopen this ticket and provide a more useful crashlog. But keep in mind that everything concerning mail transfer (sending, exporting, etc) is currently *very* unstable in 2.7-dev and may cause all funny kinds of crashes.

comment:3 Changed 4 years ago by damato

  • Component changed from undefined to mail import/export

comment:4 Changed 4 years ago by damato

  • Description modified (diff)
  • Milestone changed from YAM 2.7 to YAM 2.6p1
  • Resolution fixed deleted
  • Status changed from closed to reopened

reopened due to upcoming merge on 2.6p1 branch.

comment:5 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4999]) * YAM_MA.c: when exporting mails the file name returned by the file requester

is now checked to be non-empty. Although I could not reproduce ticket #154
this should fix it and thus closes #154.

comment:6 in reply to: ↑ 2 Changed 4 years ago by hypexed

Replying to thboeckel:

Please note that the attached crashlog has absolutely nothing in common with the stated issue. The crashlog points to some code which is executed when downloading mails from a POP3 server.

All I can say is that's the crashlog I'm certain was saved out when it happened. So I couldn't give anything better. Yes it does look strange I agree but IIRC I checked and rechecked it to make sure I hadn't mixed it up and "recrashed" it to maje sure.

In any case the problem has been fixed so I consider this as the tracker says. Case closed. :-)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Damien Stewart(Reporter)