close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 4 years ago

#159 closed bug (fixed)

ARexx help command produce Hits and output trash

Reported by: opiopi Owned by:
Priority: normal Milestone: YAM 2.6p1
Component: ARexx interface Version: 2.6
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

As the Summary say ARexx help command produce Hits and output trash.

The cause is that the for loop in rexx/help.c line 68 does not
find the end of the rxs_commandlist.

A possible solution is to terminate the list in Rexx.c like
in the attached patch file so the loop always find the end.

Is it ok if i commit the patch?

Attachments (1)

Rexx.c.diff (371 bytes) - added by opiopi 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by opiopi

comment:1 Changed 5 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [4673]) * Rexx.c, rexx/help.c: added terminating dummy entry to avoid a crash in the

ARexx HELP implementation. This closes #159.

comment:2 Changed 5 years ago by tboeckel

Hi Frank!
I just noticed that you also supplied a patch to fix this bug. It seems I read a bit too fast and fixed the bug faster than reading your report including the patch completely. I really have to appologize for this!

Your patch was exactly the correct thing to do. But there was one little notion missing. YAM uses a binary search for the command lookup which takes the number of array entries as a parameter. The dummy entry must be excluded from this number, otherwise the search would cause other crashes or even refuse certain commands although they exist.

Please continue to contribute patches like this or even commit them directly to the repository. Neither Jens nor me are perfect either and both of us already commited "half" patches.

comment:3 Changed 5 years ago by opiopi

No problem. The mainpoint is that the bug is fixed.

I saw the bsearch issue as i view into your patch.
So your full patch is better as my not complete patch. :-)

comment:4 Changed 5 years ago by damato

  • Milestone set to YAM 2.7
  • Priority changed from undecided to normal

comment:5 Changed 4 years ago by damato

  • Description modified (diff)
  • Milestone changed from YAM 2.7 to YAM 2.6p1
  • Resolution fixed deleted
  • Status changed from closed to reopened

reopened due to upcoming merge on 2.6p1 branch.

comment:6 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4993]) * Rexx.c, rexx/help.c: added terminating dummy entry to avoid a crash in the

ARexx HELP implementation. This closes #159.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter, Participant)