close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#163 closed bug (fixed)

Download status in mail transfer window is broken

Reported by: Mike Steed <72207.463@…> Owned by:
Priority: undecided Milestone: YAM 2.7
Component: user interface Version: 2.6
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by tboeckel)

The download status display in the mail transfer window broke
in v. 2.6. It worked fine in v. 2.5.

When downloading mail via a 56K dialup connection, the number
of bytes downloaded is a very large negative number, which
increments towards zero during the download. The number of
bytes to be downloaded looks correct. The transfer rate is
impossibly large, in the hundreds of megabytes per second,
though it does decrease some during the download. The running
time looks correct, but the time left is always zero.

Here's a snapshot of the display during one recent mail
retrieval:

-118056627 B of 33.1 KB @ 442.60 MB/s

00'09" running - 00'00" left

I'm running YAM 2.6 on an A3000 with a 50 MHz 68060, under
OS 3.9.2. As mentioned I'm using a dialup connection, so the
download is relatively slow, leaving plenty of time to see
the bug.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by Mike Steed <72207.463@…>

More info on this one: I've noticed that the download status display seems to work correctly if I've told YAM to download and then delete the first item in the list of emails. If I've told YAM to just delete it without downloading it (usually the case, due to spam), then the bug appears.

comment:2 Changed 4 years ago by tboeckel

  • Description modified (diff)
  • Milestone set to YAM 2.7
  • Status changed from new to pending

Please check again with the recently released YAM 2.6p1 if this issue is still valid.

comment:3 Changed 4 years ago by tboeckel

@mike steed:

Since you replied to me in private already and confirmed that the issue is still valid with YAM 2.6p1, would you perhaps try YAM 2.7-dev? I have a quite slow Internet connection at home, too, and for me the transfer display is absolutely correct with 2.7.

comment:4 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from pending to closed

(In [5356]) * tcp/pop3.c: don't update the transfer control group while loading the mail

details for the preselection list. This will output a malformed time since
the transfer has not been started yet. This closes #163.

comment:5 Changed 4 years ago by mikesteed

I'm not sure if that's the bug or not, since the problem persists even while the mail transfer is in progress, and never appears if the first file in the list is downloaded rather than simply deleted on the server. But whatever it is, it seems to have been fixed in the v. 2.7 development release (as of 9-Oct-10).

comment:6 Changed 4 years ago by mikesteed

I'm not sure if that's the bug or not, since the problem persists even while the mail transfer is in progress, and never occurs when the first entry in the mail list is downloaded, rather than simply deleted on the server. But whatever it is, it seems to have been fixed in the 2.7 development version (as of 9-Oct-10).

Version 0, edited 4 years ago by mikesteed (next)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mike Steed(Reporter, Participant)