close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 5 years ago

#165 closed bug (fixed)

DSI crash when unselected text in mail editor

Reported by: samo79 Owned by: tboeckel
Priority: undecided Milestone:
Component: user interface Version: 2.6
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

I get a DSI crash clicking on unselected text (on mail composer) in WB menu, the text was not selected but the option to unselect still remain, so maybe must be ghosted too when not usable.

Maybe is a TextEditor bug but i'm not sure at 100%

Attachments (1)

crashlog.txt (6.8 KB) - added by damato 5 years ago.
Catched crashog

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by damato

  • Component changed from undefined to user interface
  • Description modified (diff)

Changed 5 years ago by damato

Catched crashog

comment:2 Changed 5 years ago by damato

I moved the crashlog to an attachment. So please next time do not add the crashlog directly to your bugreport message but always submit it as a *.txt attachment to bug items.

comment:3 Changed 5 years ago by tboeckel

I have read this report about ten times by now, but I cannot understand it. What does "WB menu" have to do with either YAM or TextEditor.mcc? I also tried to select some text and click somewhere else and to just click somewhere into the either selected or unselected text without any crash. But I am not sure if that is what you did, simply because I don't understand your description.

So please try to explain a bit better and more verbose how to cause the crash, if it is reproducable at all.

comment:4 Changed 5 years ago by tboeckel

Oh yes, I forgot to ask, which version of TextEditor.mcc are you talking about? The latest release (15.33) or some other version?

comment:5 Changed 5 years ago by samo79

Well first of all i'm using latest YAM 2.7 nighly with MCC TextEditor 15.33 (AmigaOS 4.1 Update 2)

Having said that, this is a (step by step) guide to be able to reproduce this DSI:

  • Start YAM :-))
  • Go in "incoming" section (mail arrived at the left)
  • Now double click on any of this mail arrived in order to open it in a new window
  • Now go to the WB menu and select: Edit --> Select none

You don't need to have selected text before, just click on "select none"

This option is always active also if you didn't select any text before.

comment:6 Changed 5 years ago by tboeckel

  • Status changed from new to accepted

comment:7 Changed 5 years ago by tboeckel

  • Owner set to tboeckel
  • Status changed from accepted to assigned

comment:8 Changed 5 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in the next release of TextEditor.mcc.

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Samir Hawamdeh(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)