close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#173 closed bug (fixed)

Rebuild Folder Index issue

Reported by: enzobarba@… Owned by: tboeckel
Priority: high Milestone: YAM 2.6p1
Component: mail indexing Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by damato)

Hi,
from some YAM 2.7 nightly build the 'rebuild index' doesn't work.
In YAM 2.6 it works.

to reproduce the issue:

  1. select a mail-folder with some mail
  2. rightclick -> rebuild index
  3. the index will be resetted, but the mails are still there.

(I open yam2.6 stable rel. and I make the same steps to
rebuild index correctly)

I'm on PEG2 G4, MOS 1.4.5 latest ambient beta

Attachments (1)

yam.log.zip (14.6 KB) - added by rmsyam 4 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 4 years ago by damato

what exactly do you mean by "the mails are still there"? What should happen instead? and can you please check if the OS3 version running under MOS works different?

comment:2 follow-ups: Changed 4 years ago by tboeckel

  • Status changed from new to accepted

Please provide a FOLDER+MAIL debug log created by the debug version of the next nightly build. See http://faq.yam.ch/content/12/54/en/basics-about-yam_s-debugging-facilities.html for details about YAM's debugging facilities.

Jens, did you change anything concerning the MorphOS builds? We didn't change anything regarding index building or directory scanning. Yet this is the second report about this problem on MorphOS.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 4 years ago by damato

Replying to thboeckel:

Jens, did you change anything concerning the MorphOS builds? We didn't change anything regarding index building or directory scanning. Yet this is the second report about this problem on MorphOS.

I only changed the MOS SDK to the very latest version available when it was released for MOS 2.5. Perhaps this might be the reason why things are working different now. As the author is runing MOS 1.4.5 I am curious if Christoph might run also 1.4.5. So this would then point out an incompatibility of the MOS 2.5 SDK to older MOS versions.

comment:4 in reply to: ↑ 2 Changed 4 years ago by anonymous

Replying to thboeckel:

Please provide a FOLDER+MAIL debug log created by the debug version of the next nightly build. See http://faq.yam.ch/content/12/54/en/basics-about-yam_s-debugging-facilities.html for details about YAM's debugging facilities.

I'll try to do that debuglogs;
at present I made some tests:

  1. the OS3 version freeze during startup on my Peg2/MOS1.4.5
  2. i'm trying the latest yam2.7-nightly DEBUG version.. and it works

so:
--YAM2.7mos latest nightly build -> "rebuild index" get 0 (even on folders with many mails in)
--YAM2.7mos latest nightly build DEBUG ver. -> "rebuild index" return the exact number of mails in the folder

comment:5 Changed 4 years ago by damato

  • Component changed from undefined to mail indexing
  • Milestone set to YAM 2.7
  • Priority changed from undecided to high

comment:6 in reply to: ↑ 3 Changed 4 years ago by tboeckel

Replying to damato:

I only changed the MOS SDK to the very latest version available when it was
released for MOS 2.5. Perhaps this might be the reason why things are
working different now. As the author is runing MOS 1.4.5 I am curious if
Christoph might run also 1.4.5. So this would then point out an
incompatibility of the MOS 2.5 SDK to older MOS versions.

According to one of his last private mails Christoph is using MOS 2.4 and 2.5.

comment:7 in reply to: ↑ description Changed 4 years ago by rmsyam

Replying to enzobarba@…:

Hi,
from some YAM 2.7 nightly build the 'rebuild index' doesn't work.
In YAM 2.6 it works.

to reproduce the issue:

  1. select a mail-folder with some mail
  2. rightclick -> rebuild index
  3. the index will be resetted, but the mails are still there.

(I open yam2.6 stable rel. and I make the same steps to
rebuild index correctly)

I'm on PEG2 G4, MOS 1.4.5 latest ambient beta

Hi,

it seems that I have excately the same problem using YAM with MorphOS!

I use MorphOS 2.5 though.

comment:8 Changed 4 years ago by tboeckel

  • Owner set to tboeckel
  • Status changed from accepted to assigned

I think I found the bug, but I really wonder why it did not occur with OS3 which also uses the reimplemented function. Please try again with the next nightly build. If the problem still persists, then please reopen this bug.

comment:9 follow-up: Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4782]) * extrasrc/ExamineDir.c: the ExamineDir() reimplementation directly returned

the type value from the ExAll() call instead of converting it to the
ExamineDir() style. This confused the calling function to ignore files
which certainly should have been found. This closes #173.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 4 years ago by rmsyam

Replying to thboeckel:

(In [4782]) * extrasrc/ExamineDir.c: the ExamineDir() reimplementation directly returned

the type value from the ExAll() call instead of converting it to the
ExamineDir() style. This confused the calling function to ignore files
which certainly should have been found. This closes #173.

Hi, I tested the new version from yesterday with this fix but here under MorphOS 2.5 it still doesn't seems to work! Same behavour as before, after an Update index there are always 0 Mails shown in the drawer. It still works correctly with the debug version though, which is: after an Update index the correct number of Mails in a directory are displayed.

comment:11 Changed 4 years ago by damato

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:12 in reply to: ↑ 10 ; follow-up: Changed 4 years ago by enzobarba@…

Replying to rmsyam:

Hi, I tested the new version from yesterday with this fix but here under MorphOS 2.5 it still doesn't > seems to work! Same behavour as before, after an Update index there are always 0 Mails shown > in the drawer. It still works correctly with the debug version though, which is: after an Update index > the correct number of Mails in a directory are displayed.

same here on my mos1.4.5 and yam latest nightly build

comment:13 in reply to: ↑ 12 Changed 4 years ago by rmsyam

Replying to enzobarba@…:

Replying to rmsyam:

Hi, I tested the new version from yesterday with this fix but here under MorphOS 2.5 it still doesn't > seems to work! Same behavour as before, after an Update index there are always 0 Mails shown > in the drawer. It still works correctly with the debug version though, which is: after an Update index > the correct number of Mails in a directory are displayed.

same here on my mos1.4.5 and yam latest nightly build

Hi, any news yet to solve this problem/bug?

comment:14 follow-up: Changed 4 years ago by tboeckel

Maybe yes, maybe no. I just modified some stuff concerning error handling and possible wrong interpretations in certain error situations.

Please try again with the next nightly build. A FOLDER+MAIL+@TAGS log might be interesting in case the scanning operation still fails.

comment:15 Changed 4 years ago by enzobarba@…

the bug is still here, with nightly b. 27072010
on my mos1.4.5
(the debug version works good; production version no. as before)

comment:16 in reply to: ↑ 14 ; follow-up: Changed 4 years ago by enzobarba@…

Replying to thboeckel:

Please try again with the next nightly build. A FOLDER+MAIL+@TAGS log might be interesting in case the scanning operation still fails.

the bug is still here, with nightly b. 27072010
on my mos1.4.5
(the debug version works good; production version no. as before)

comment:17 in reply to: ↑ 16 ; follow-up: Changed 4 years ago by tboeckel

Replying to enzobarba@…:

Replying to thboeckel:

Please try again with the next nightly build. A FOLDER+MAIL+@TAGS log might be interesting in case the scanning operation still fails.

the bug is still here, with nightly b. 27072010
on my mos1.4.5
(the debug version works good; production version no. as before)

Then please provide the requested log (FOLDER, MAIL and @TAGS).

Changed 4 years ago by rmsyam

comment:18 in reply to: ↑ 17 Changed 4 years ago by rmsyam

Replying to thboeckel:

Replying to enzobarba@…:

Replying to thboeckel:

Please try again with the next nightly build. A FOLDER+MAIL+@TAGS log might be interesting in case the scanning operation still fails.

the bug is still here, with nightly b. 27072010
on my mos1.4.5
(the debug version works good; production version no. as before)

Then please provide the requested log (FOLDER, MAIL and @TAGS).

Hi, it still doesn't work neither on MorphOS 2.5 with the normal version but it works with the debug version! I generated a log as you asked above with the debug version.

Last edited 4 years ago by rmsyam (previous) (diff)

comment:19 follow-up: Changed 4 years ago by damato

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4806]) * extrasrc.h, extrasrc/ExamineDir.c, extrasrc/AllocSysObject.c: replaced

incorrectly used "PPC" defines with the correct "PPC" ones. This was
indeed the reason why the MorphOS compile showed a strange behaviour when
running the index rescanning after having switched to MOS 2.5 SDK. This
should finally fix #173.

comment:20 in reply to: ↑ 19 Changed 4 years ago by enzobarba@…

Replying to damato:

(In [4806]) * extrasrc.h, extrasrc/ExamineDir.c, extrasrc/AllocSysObject.c: replaced

incorrectly used "PPC" defines with the correct "PPC" ones. This was
indeed the reason why the MorphOS compile showed a strange behaviour when
running the index rescanning after having switched to MOS 2.5 SDK. This
should finally fix #173.

Yes!
now here it's working.

thanks!

comment:21 Changed 4 years ago by damato

  • Description modified (diff)
  • Milestone changed from YAM 2.7 to YAM 2.6p1

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • enzobarba@…(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)