close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

#178 closed bug (fixed)

YAM tries to close file twice -> recoverable alert on exit

Reported by: padrino Owned by:
Priority: high Milestone: YAM 2.7
Component: user interface Version: nightly build
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

YAM 2.7-dev [OS4/PPC] (14.08.2010)

First of all, this does not happen with the debug version, so I cannot provide you with a debug log.
Second there is nothing on the grim reaper side.

I only know, when I quit YAM I get a dos requester complaining that a file that was already closed was closed a second time, then there is a yellow guru.

If there is anything I can do to give you some more info, please tell me.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by tboeckel

I just tried that nightly build. Ran YAM and quitted it again => no problem.

If there is something else to do to let the issue happen then this tiny bit of information is missing in your report.

comment:2 Changed 4 years ago by damato

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.7
  • Priority changed from undecided to high
  • Severity changed from major to minor
  • Status changed from new to accepted

Ok. I tried to reproduce the issue as well. So I compiled myself a non-debug version and simply started it and quit YAM immediately. And here it also seems to happen. The requester that comes up seems to be comming from dos.library directly reminding the user that an already closed file was tried to be closed a second time. So there indeed seems to be some internal problem which might need some further investigation. Let's see if SnoopDOS&Co can help in finding out why the debug version works while the non-debug version shows the problem on quit.

comment:3 Changed 4 years ago by damato

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [4915]) * extrasrc/NewReadArgs.c,h: unified the "public" and "private" NewRDArgs

data structure as we are utilizing it anyway completely. In addition, the
data alignment enforcement has been removed. All together this fixes #178
where a Close() has been executed on an invalid file handle due to the
wrong structure alignment of NewRDArgs.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mario Cattaneo(Reporter)