close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 2 years ago

#181 closed bug (invalid)

YAM crashes when deleting mails from trashcan by hand

Reported by: padrino Owned by:
Priority: undecided Milestone:
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

YAM 2.7-dev [OS4/PPC] (17.08.2010) Copyright (C) 2000-2010 YAM Open Source Team

I am not deleting Mails at once, but let YAM put them to trashcan instead.
When I then open the trashcan folder, mark all the mails (say 15-20 in total) and press the delete button from the toolbar YAM crashes.

Find attached a GR log of the non debug version an a sashimi log of the debug version (set @all all) of the same built

Attachments (2)

Crashlog_YAM_2010-08-17_14-34-57.txt (29.8 KB) - added by padrino 4 years ago.
GR log
sashimi.out (5.5 KB) - added by padrino 4 years ago.
debug log

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by padrino

GR log

Changed 4 years ago by padrino

debug log

comment:1 Changed 4 years ago by damato

  • Status changed from new to pending

Sorry, but I cannot reproduce the problem here. Here I perfectly deleted about 2000 mails from the trashcan by hand without a single crash. Is the problem reproducable for you or did it only happen once?

comment:2 Changed 4 years ago by tboeckel

Do you have a debug kernel running on OS4? I just ask because the register r9 contains the very suspective value 0xccccccc. This usually points to some double Remove() calls.

comment:3 Changed 4 years ago by tboeckel

One additional question. How is NListviews.mcp configured on your system? Please tell me your settings for the horizontal and vertical scrollbar. Are these set to "automatic"?

comment:4 Changed 4 years ago by padrino

Yes, I am using a debug kernel (to get the most infos into logs?).
And NLV is both set to "FullAuto".

comment:5 Changed 4 years ago by padrino

It's me again.
I assume it's related to the "FullAuto"-Setting. Cause when I set it to "Auto" no crash occures.
Well, now it also crashed when when I just switch "special" folders (find a log for that attached, though probably not usefull).

It seems related to the phenomenon that one folder here does always turn on/off the sliders when active. Seems like YAM/NLV cannot decide whether sliders are needed or not an therefor switches arround all the time. Now when I switch from that folder to another YAM crashes. Which it did not in the past.
Think I will reintall older NLV to see if the crash is gone then (again), the "jumping" will of course remain.

I think I talked about this to you some time ago. Still I was not able to have a perct config (best default) to give to you.
Maybe I should try another approach, so you can reproduce it.

comment:6 Changed 2 years ago by tboeckel

  • Resolution set to invalid
  • Status changed from pending to closed

Closing this ticket as this is no bug in YAM but in NList. If you are able to reproduce the crash easily then please open a new bug in NList's bugtracker.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mario Cattaneo(Reporter, Participant)