close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

#187 closed bug (fixed)

clicking on the result of a search opens 2 readwindows

Reported by: opiopi Owned by: tboeckel
Priority: normal Milestone: YAM 2.7
Component: user interface Version: nightly build
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Step by step to reproduce:

  1. be sure you set up YAM to use readwindows.
  2. go to a folder with some mails.
  3. do a search and be sure you get some mazches.
  4. double click on a search result.

At this point YAM opens 2 read windows:

  1. the active Mail from the mainwindow
  2. the selected mail from the search results

YAM should IMHO only open window 2.

used version:
YAM 2.7-dev [OS3/m68k] date 24.08.2010 (build 20100824)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by tboeckel

  • Owner set to tboeckel
  • Status changed from new to assigned

comment:2 Changed 4 years ago by tboeckel

  • Milestone set to YAM 2.7
  • Priority changed from undecided to normal
  • Severity changed from major to minor

comment:3 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [4983]) * mui/MainMailList.c, YAM_FI.c: the main mail list object can now be told not

to handle double clicks itself but to let the surrounding stuff handle this
case. For the mail search window this caused multiple read windows to be
opened, because the double click in the result list caused the click to be
handled twice, but the class itself and once again by the search window.
This closes #187.

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter)
  • Thore Böckelmann(Owner, Participant)