close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#192 closed bug (fixed)

YAM crash if you click 'abort' in the transfer window.

Reported by: opiopi Owned by: tboeckel
Priority: high Milestone: YAM 2.7
Component: TCP/IP interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

As the Summary say:
YAM crash if you click 'abort' in the transfer window.

Simply try to get mails and if the transfer window is open
then click on 'abort' -> bum...

I attach a logfile with the hits. (MuToolsHits-27.08.2010.txt)
here is no YAM reference in the stack trace but maybe the
file helps to find the cause.

used version:
YAM 2.7-dev [OS3/m68k] (27.08.2010)

Attachments (2)

MuToolsHits-27.08.2010.txt (10.1 KB) - added by opiopi 4 years ago.
sashimi.out (20.7 KB) - added by opiopi 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by opiopi

comment:1 Changed 4 years ago by tboeckel

  • Component changed from undefined to TCP/IP interface
  • Milestone set to YAM 2.7
  • Priority changed from undecided to high

comment:2 Changed 4 years ago by tboeckel

  • Owner set to tboeckel
  • Status changed from new to assigned

No matter how often I interrupt an SMTP session I cannot make YAM crash. And I don't need to be very fast because of my crawling slow connection (53.6K/s at most). What makes the search for a potential bug in YAM even harder is the fact that your log doesn't even mention YAM in the stack backtrace, only as current process.

Can you provide a NET+UTIL log please? Perhaps this might enlight us.

comment:3 Changed 4 years ago by opiopi

Ok then here some hints to find the bug:

  1. You must set a command in config->New mail->Command

(here it's "run >NIL: c:play16 Work:Prefs/Soundprefs/POST.iff")

  1. You must at least download one mail.
  2. The crash seems to be time critical. E.g. i don't get a crash

if i see the debug output on the outpu window. If i iconify the
debug output window then i get always the crash.

  1. The crash happen in the the YAM_UT.c->SyncLaunchCommand()

function at the SystemTags() call. That may explain why here
is no YAM reference in the stack trace. But my knowledge about
the function in NULL. Maybe a tag is missed or wrong!?

  1. I attach a file (sashimi.out) with the last debug lines

before the crash and the Hits itself. I redirect the debug
tools output to the same debug console.

HTH

BTW: Do we really need the ENTER() and RETURN() macros in
YAM.c->Root_GlobalDispatcher()? It makes a lot of noise on
the debug console also if YAM is doing nothing. IMHO the macros
makes not much sense here. I know i can disable some output
by setting the yamdebug variable but most i use '@all all'
because it's easier for me and i don't have to remember which
combination in yamdebug i need.

Changed 4 years ago by opiopi

comment:4 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [5121]) * YAM_UT.c: launching a command synchronously with output redirected to the

current standard input/output channels would crash sooner or later, because
YAM closed exactly these channels. Now the channels are closed only if YAM
did open them explicitly before. This closes #192.

comment:5 Changed 4 years ago by tboeckel

Many thanks for this hint.

But if you want to let YAM play a sound after receiving some mails, you should use YAM's own sound playing abilities instead of doing this by using an external command.

comment:6 Changed 4 years ago by opiopi

This config entry is very old. Maybe at this time YAM was not able
to play sounds itself!? I don't remember why it is still here...
But with that entry the bug was easier to find. :-)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)