close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#199 closed bug (fixed)

error message when doubleclick on URL

Reported by: opiopi Owned by:
Priority: normal Milestone: YAM 2.7
Component: ARexx interface Version: nightly build
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

I don't use this feature for long time but today i get a
error message when doubleclick on URL even if i use the
original script 'GotoURL.yam' from the rexx drawer:
The error message is:

Ausführung des ARexx-Kommandos 'YAM:Rexx/GotoURL.yam http://trac.yam.ch/ticket/190#comment:6' fehlgeschlagen (Fehler 0).
Bitte stellen Sie sicher, dass die Datei existiert und ein korrektes ARexx-Skript ist.

(BTW: I'm sure it exists and is a valid ARexx-Skript!)

I configured YAM like this:
Beim Doppelklick auf einen URL:
Skript: YAM:Rexx/GotoURL.yam %p -> ARexx
'Öffne Konsolenfenster' and 'Warte auf Beendigung' both are unchecked.

It was working this way in the past with without such error message.

If i enable 'Warte auf Beendigung' or run it as 'AmigaDOS' (with Script Bit set)
or as 'rx YAM:Rexx/GotoURL.yam %p' then i get no error message.

So a possible solution would be to not check the return value if
'ARexx' is set *and* 'Warte auf Beendigung' isn't set.

Or at least a hint in the guide and/or bubblehelp?
So maybe this ticket is not a bug but a enhancement request.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [5142]) * Rexx.c: in case YAM receives an asynchronous reply to a former

SendRexxCommand() call an error message will only be displayed if the
result is not equal to zero. This is now the same reaction as for a
synchronous ARexx script. This closes #199.

comment:2 Changed 4 years ago by tboeckel

  • Milestone set to YAM 2.7

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter)