close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#213 closed bug (invalid)

YAM doesn't show the very first command send to the server.

Reported by: opiopi Owned by:
Priority: low Milestone: YAM 2.6p1
Component: TCP/IP interface Version: 2.6
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

As the Summary say YAM doesn't show the very first command send to the server.

Step by step to reproduce:

  1. Start YAM in debug mode.
  2. Get mails.
  3. The first line in debug output is anything like:

SERVER[0065]: +OK hello from popgate 2.46.7 on pop105.plus.mail.ac4.yahoo.com

I miss here the command YAM was send to the server before the server respond.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by tboeckel

  • Resolution set to invalid
  • Status changed from new to closed

There is nothing missing, because nothing has been sent out before.

Look at src/tcp/pop3.c line 312. The first "command" YAM sends to the POP3 server is POPCMD_CONNECT, which is an empty string. Hence nothing is send and there is nothing to print out.

comment:2 Changed 4 years ago by tboeckel

For the 2.6p1 branch this is src/YAM_TR.c line 3231.

comment:3 Changed 4 years ago by opiopi

Sorry i don't look at the source because i try to test programs
like a DAU. So i see only a 'hello' from the server and think
why does he say hello without i spoke to him?
I was expecting a 'Connect to Server....' or something like that.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Frank Weber(Reporter, Participant)