close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 19 months ago

#220 closed bug (fixed)

A "in mail" search in incoming folder will look up YAM when pulling mails

Reported by: padrino Owned by:
Priority: undecided Milestone: YAM 2.8
Component: mail filtering Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

YAM 2.7-dev [OS4/PPC] (25.09.2010) Copyright (C) 2000-2010 YAM Open Source Team

Try to perform a search in "head" or "body" of a mail for "xxx" in "incoming". Now when the search is running (hope you have a folder where it can take a while ;)) push the "get mail" image. Make sure you have new mail waiting to be fetched.
YAM will then lookup/freeze.
I know it's not nice to change the "database" where YAM is searching in, but YAM should never lock up. Should it? ;)

Attachments (0)

Change History (10)

comment:1 Changed 4 years ago by tboeckel

  • Milestone set to YAM 2.7
  • Status changed from new to accepted

Hm, quite hard to reproduce this issue. So far I was to able to cause any lock ups, no matter how often I searched and downloaded new mails in parallel. The overall progress very much depends on MUI's event handling. Maybe I am doing it in the wrong sequence or in the wrong time frame. Most probably this issue will become more obvious as soon as I have finished the threaded POP3 download.

The filtering works like this: first get a list of all mails in a folder, then perform the search on this (fixed) list of mails. If the download process already downloaded some mails these might end up in this list. If the download process finished while the search is still running and the filtering process moves one of the new mails not yet searched through to a different folder then the search process might stumble over the no longer existing mail.

comment:2 Changed 4 years ago by padrino

  • Resolution set to fixed
  • Status changed from accepted to closed

YAM 2.7-dev [OS4/PPC] (09.10.2010) Copyright (C) 2000-2010 YAM Open Source Team

Seems the crash is gone with latest nightly built.

comment:3 Changed 4 years ago by padrino

  • Resolution fixed deleted
  • Status changed from closed to reopened

It's amazing, 10 tests caused no crash. I resolved this report and *bang*.

Seems Murphy is still with us... :-/

comment:4 Changed 3 years ago by tboeckel

  • Status changed from reopened to pending

Does this still happen with the recently added thread based POP3 download?

comment:5 Changed 3 years ago by padrino

Well, with threaded POP3 the download does not start at all.
Clicking the pop-image has no effect, then when I cancel the search the "queued" POP3 is processed.

comment:6 Changed 3 years ago by padrino

Mind to reply/comment? :)

Is it normal that the buttons does not work anymore, ie. postponed?

comment:7 Changed 3 years ago by tboeckel

  • Status changed from pending to accepted

Yes, unforturnately this is the normal case. While performing the search YAM does not execute its usual main loop (which handles *all* stuff), but lets itself execute updates of the GUI only to be a bit responsive. But starting a thread requires some communication between the main task and the thread which is not handled during the search. Hence you get the intended reaction right after the search has finished.

It seems we have to move the search to a thread as well...

Setting this ticket back to "accepted" for the time being.

comment:8 Changed 3 years ago by tboeckel

The situation should improve a bit with the next nightly build. That means that YAM will be able again to initiate a download which a search is in progress. But the download will still not be able to download a single mail, because the search process keeps the incoming folder's mail list locked which prevents the download thread from adding a new mail to the same list.

comment:9 Changed 2 years ago by damato

  • Milestone changed from YAM 2.7 to YAM 2.8

The issue seems to be partly resolved now (accordingly to thore's comments). Thus, I reschedule that ticket to be revised and checked before and eventual 2.8 release so that we can revisit the problem and see if we can get it solved completely by moving things in a separate thread.

comment:10 Changed 19 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [6307]) * YAM_FI.c: a search within a folder will now clone the folder's list of mails before performing the actual search. This makes it possible to download new mails while the search is still in progress. Please note that the search process may slow down the mail download, because it is not yet done in a separate thread. This finally closes #220.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mario Cattaneo(Reporter, Participant)