close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 4 years ago

Last modified 2 years ago

#240 closed bug (fixed)

Problem with displaying some quoted printable encoding mails

Reported by: anonymous Owned by:
Priority: normal Milestone: YAM 2.8
Component: MIME handling Version: 2.6p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

For some while since upgrading to yam 2.6 I've been seeing some emails that don't get displayed correctly when the content is encoded in 'quoted printable'

Here is fragment from the display of a mail from a mail from my mailing list


Just a little mail to let you know that Claude is playing on Thursday 16th=

of December 2010 at the R.M.A. Tavern (The Gun Room), 58 Cromwell Road,=
Portsmouth.

Ticket =C2=A35 at the doors.

Concert at 9pm.


As you can see the text has been displayed undecoded. These mails always used to work with Yam 2.5 and earlier, and as far as I am aware display correctly in other mail clients

I've been short of time else I would havwe reported this earlier! I'l attach a copy of the message above

Attachments (2)

Claude_Bourbon_s__Christmas_concert_at_the_R.M.A._Tavern__Gun_Room_,_Portsmouth.msg (4.6 KB) - added by andy@… 4 years ago.
Email in quoted printable format
no-mime.msg (3.2 KB) - added by Elwood 2 years ago.

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by andy@…

Email in quoted printable format

comment:1 follow-up: Changed 4 years ago by tboeckel

  • Milestone set to YAM 2.7

I took a deeper look at the mail and found out that it violates the rules defined by RFC 2049. Although it has the necessary "Content-Type" and "Content-Transfer-Encoding" lines, it is missing the "MIME-Version" header line. Without this YAM will treat the mail as non-MIME conforming and hence display it as 7bit ASCII instead of the given encoding.

Maybe YAM 2.5 was a bit less restrictive in this case, but from YAM 2.6 on the rules are obeyed.

Maybe there is a chance to convince the administrator of that site to send out MIME conformant mails. Direct him to http://www.ietf.org/rfc/rfc2049.txt for the details. The most important stuff is stated just below the line "A mail user agent that is MIME-conformant MUST:". Note the word "MUST"!

And yes, you are right, ThunderBird displays this mail correctly. But what are rules for if everybody disobeys them or bends them to his own requirements?

A possible solution would be not to enforce 7bit ASCII for such mails, but to take them as they are and output a warning.

Jens, what do you think?

comment:2 Changed 4 years ago by tboeckel

  • Status changed from new to accepted

comment:3 in reply to: ↑ 1 Changed 4 years ago by damato

Replying to thboeckel:

Jens, what do you think?

I have the same opinion. One of YAMs' features is, that it tries to be as RFC compliant as possible. So if a mail is missing the MIME-Version: header it should be treated as being NON Mime compliant in my understanding.
For the possible solution I am still unsure. Warnings are often simply ignored and it might be that people will think that the Warning is a bug since the message will be displayed correctly.

comment:4 Changed 4 years ago by tboeckel

  • Resolution set to wontfix
  • Status changed from accepted to closed

Well, then I opt for leaving everything as it is. If a mailer produces non-MIME compliant mails then this is not a bug of YAM is such mail cannot be displayed properly. Although other clients silently ignore such errors I must second Jens' opinion. Issuing a warning but (incorrectly) displaying a mail text as it "might" be correct will just hide possible future problems. Better solve the problem at its roots: convince you mailing list admin to produce RFC 2049 conforming mails. That's what rules are made for.

comment:5 Changed 4 years ago by andy@…

Thanks for looking into this. Whilst it was at the back of my mind that the mails themselves might be "buggy" the fact that it worked in 2.5, firebird and others made me think otherwise. I'm effectively the mailing list admin :-) so I'd best study my perl scripts ... and that RFC. Suprised that perl MAIL::SMTP doesn't take care of that automatically but then that's not your problem!

comment:6 follow-up: Changed 3 years ago by damato

  • Component changed from undefined to MIME handling
  • Priority changed from undecided to normal

comment:7 in reply to: ↑ 6 Changed 2 years ago by Elwood

When you are not responsible of the emails you receive there is nothing you can do. So you are stuck with the annoying requester :-( This is even stupid, from my POV, as Yam still displays the content when the requester is acknowledged!
This is so annoying that I a french user switched to Simplemail. I'm thinking the same now :-(

comment:8 follow-up: Changed 2 years ago by damato

What exactly is your problem? That YAM outputs a warning requester? If so, please attach the mail in question and we will investigate whos fault that is.

Changed 2 years ago by Elwood

comment:9 in reply to: ↑ 8 Changed 2 years ago by Elwood

Yes the requester is annoying. Attached an example...

comment:10 Changed 2 years ago by tboeckel

  • Resolution changed from wontfix to fixed

(In [6107]) * YAM_ER.c, YAM_RE.c: implemented new function ER_NewWarning(). This servers exactly the same purpose as ER_NewError() but will not open the error window. It will be used in cases a mail does not contain the usual MIME-Version header line, for example, to record such error, but to not annoy the user too many error messages. This finally closes #240.

comment:11 follow-up: Changed 2 years ago by tboeckel

  • Milestone changed from YAM 2.7 to YAM 2.8

comment:12 in reply to: ↑ 11 Changed 2 years ago by Elwood

Replying to thboeckel:
Thanks Thore.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

Nobody is currently notified about changes to this ticket.