close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#243 closed bug (worksforme)

Crash after deletion

Reported by: Raziel Owned by:
Priority: high Milestone: YAM 2.7
Component: XPK compression Version: 2.6p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

YAM2.6p1 - AmigaOS4.1 (all updates)

I got two times a crash after deleting a mail.
I was able to reproduce it, the problem was copying a mail to a password protected folder *before* which worked very well, but deleting any mail afterwards leads to crash

Attachments (1)

Crashlog_YAM_2010-12-23_14-07-29.txt (36.6 KB) - added by Raziel 3 years ago.
Grim Reaper

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by Raziel

Grim Reaper

comment:1 Changed 3 years ago by tboeckel

  • Status changed from new to accepted

This might be related to the recently fixed ticket #234.

If possible please try to reproduce this issue with the current YAM 2.7-dev.

comment:2 Changed 3 years ago by tboeckel

  • Milestone set to YAM 2.7

I tried to reproduce this issue with the current YAM 2.7-dev but I was not able to force a crash at all. I did the following:

  1. set up a password for a folder
  2. copy some mails to this folder
  3. restarted YAM to let it forget about the formerly entered password
  4. copy another mail to that folder, entering the password was necessary for this
  5. go to the folder and open a mail in a separate read window
  6. delete this mail

At least this is how I understand your description. If I did anything wrong please tell me.

comment:3 Changed 3 years ago by tboeckel

  • Status changed from accepted to pending

comment:4 Changed 3 years ago by Raziel

Not entirely

steps 1 through 4 were correct

step 5 would be to not enter the directory (at least thats not what i did but in general it shouldn't matter) but delete whatever mail in whatever other drawer.

i.e. i copy a mail from "incoming" to "personal" (password) and then delete a mail from "outdated"

comment:5 follow-up: Changed 3 years ago by tboeckel

  • Priority changed from undecided to high

I am sorry, but I cannot reproduce this issue, neither with YAM 2.7-dev nor with YAM 2.6p1. Does it happen every time, or does the crash occur more or less randomly?

comment:6 in reply to: ↑ 5 ; follow-up: Changed 3 years ago by Raziel

I can't reproduce it either anymore :-/

It could maybe have been a crash from the xpk module that does the crypting?
I am using xpkIDEA which is still 68k and might be the reason why YAM came up with the crash.

This is only brainstorming of course

comment:7 in reply to: ↑ 6 Changed 3 years ago by tboeckel

  • Resolution set to worksforme
  • Status changed from pending to closed

Replying to Raziel:

I am using xpkIDEA which is still 68k and might be the reason why YAM came up with the crash.

This is definitely a new fact you did not mention before. I just tried plain password protection for the folder, no XPK compression/encryption. Of course a buggy XPK sublibrary may cause any kind of funny effects, both directly and indirectly. YAM can only rely on the assumption that the XPK package is working properly.

I'll close this ticket for the moment as "works for me". If the crash happens again for you then feel free to reopen it.

comment:8 Changed 2 years ago by damato

  • Component changed from undefined to XPK compression

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Hubert Maier(Reporter, Participant)