close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#256 closed bug (worksforme)

Crash after downloading mail

Reported by: hypex Owned by:
Priority: undecided Milestone:
Component: undefined Version: 2.6p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Hello.

While YAM was loaded I started it downloading my emails while I switched to Workbench. I then got a Grim Reaper! I went back to the YAM screen and the window had came up telling me it had downloaded. So it looks like it crashed after downloading the mail and finishing the operation. This bug may be rare as I haven't seen it before and may be hard to reproduce.

Attached is crash log from my AmigaOS4.1.2 system.

Attachments (3)

Crashlog_YAM_2011-03-12_00-41-30.txt (29.1 KB) - added by hypex 4 years ago.
Crash
Crashlog_YAM_2011-03-12_00-41-30.2.txt (29.1 KB) - added by hypex 4 years ago.
IP was messed up here
Crashlog_YAM_2011-03-12_00-42-06.txt (28.9 KB) - added by Damien Stewart <hypexed@…> 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by hypex

Crash

Changed 4 years ago by hypex

IP was messed up here

Changed 4 years ago by Damien Stewart <hypexed@…>

comment:1 Changed 4 years ago by Damien Stewart <hypexed@…>

Sorry added log twice. The new one has the log where the instruction pointer goes haywire. :-)

But I know by the time that happens such a log is practically??useless.

comment:2 Changed 4 years ago by tboeckel

  • Status changed from new to pending

This kind of crash is indeed quite hard to catch. I suppose YAM's "keep the connection alive" feature is causing this, since the crashlog points to that code location. You might want to try to set the variable "KeepAliveInterval" in YAM's advanced section to zero using a text editor. The "keep alive" facility is used for preselection only, so if you don't use that there should be no negative impact for you.

Another possible solution would be to try the current nightly builds of YAM 2.7-dev. Since there have been substantial modifications to the POP3 stuff it is very likely that the bug has been fixed there already.

comment:3 Changed 4 years ago by Damien Stewart <hypexed@…>

Okay thanks for the info. I'll check that one out.

I am usually a user of the nightly builds but once I have a stable version I like to stick with it. And the builds usually time out, mostly at the worse time. Forcing me to update it again. :-)

comment:4 Changed 4 years ago by tboeckel

Any news on this issue?

comment:5 follow-up: Changed 3 years ago by tboeckel

  • Resolution set to worksforme
  • Status changed from pending to closed

Please try to reproduce this issue with YAM 2.7. If it still happens then please reopen this ticket.

comment:6 in reply to: ↑ 5 Changed 3 years ago by hypex

Hi I just tested with YAM 2.7. It looks fine. Howeever I did send myself an email and attempt to download it while quickly switchng to my Workbench. :-)

Not exactly the same. Will try again when I know I have mail just in case.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Damien Stewart(Reporter, Participant)