close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

#266 closed bug (fixed)

"IN" filters do not work in YAM nightly build

Reported by: chris@… Owned by: tboeckel
Priority: undecided Milestone:
Component: mail filtering Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

A filter set to search a file does not work in the latest nightly build 26-06-2011. This function did work in YAM 2.6p1.

To reproduce:
Set up a new filter with the following details:

Comparison:
Search in From
IN .test-addresses
Click on the arrow next to .test-addresses and type an email address to apply the filter to. Save and close the new file.

Action:
Move to Folder

Clicking Filter will not filter the expected email(s). Setting a From filter with an address, rather than creating a file with a list of addresses does work as expected however.

Snoopy reports the file is getting opened, so that isn't the cause of the problem:
00036 : YAM : o.k. = Open(".test-addresses",OLD) = [0x15DF1EC0] [222uS]

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by tboeckel

  • Owner set to tboeckel
  • Status changed from new to assigned

Ok, this was an easy one. First of all, searching using a pattern file was really abandoned when fast Boyer-Moore string search was introduced. Second, searching using a pattern file definitely requires AmigaDOS patterns to be used.

comment:2 Changed 3 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [5713]) * YAM_FI.c, mui/SearchControlGroup.c: doing a search with a pattern file is now

working again, but it must be done using AmigaDOS patterns. Hence these are
activated automatically now. This closes #266.

Last edited 3 years ago by tboeckel (previous) (diff)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • chris@…(Reporter)
  • Thore Böckelmann(Owner, Participant)