close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

#278 closed enhancement (wontfix)

Remove necessity to double-hit Enter in To: field

Reported by: Sprocki Owned by:
Priority: undecided Milestone:
Component: user interface Version: 2.6p1
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

Please remove the necessity to hit Enter key twice when writing recipients into the To: (CC:, BCC:) field.

Steps to reproduce

  1. Edit new mail.
  2. Add a recipient by entering his name.
  3. Hit Enter key.

Expected results

On pressing Enter key, YAM cycles to the next textfield which is subject.

Actual results

YAM selects the chosen address book entry, adds a comma and stays inside the address textfield, awaiting more addresses.

Regression

The standard use case for writing mails is to have just one recipient. Always hitting Return twice is a bit annoying. In case someone needs to address multiple persons he can add comma as it worked in former versions of YAM.

Notes

YAM 2.6p1 [MOS/PPC] on MorphOS 2.7.

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by damato

  • Resolution set to wontfix
  • Status changed from new to closed

First of all thanks for your nice reports. Always a pleasure to read/follow them as they are so nicely explained. Please go on with that and report whatever you want/find.

However, regarding this report I do have to object. Seeing how other clients handle this situation YAM is perfectly in line (there also ENTER simply resolves the entered part and continues the recipient entry operation. But of course you are right, pressing ENTER/RETURN twice seems a bit annoying when you mostly enter one address. But then this is exactly the reason why you are supposed to use the TAB key instead. Like with other clients YAM will also jump to the next line (subject) when you immediately press TAB instead of ENTER. And IMHO this seems to be the best approach.

Thus, simply adapt yourself and in case you want to quickly enter only one recipient, enter his/her name, alternatively select him/her via the addressmatchlist and then don't use the ENTER/RETURN key, but the TAB key instead to jump to the subject string object.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Markus Lunk(Reporter)