close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#279 closed bug (fixed)

Accept pipe symbol as part of URL

Reported by: Sprocki Owned by:
Priority: undecided Milestone: YAM 2.7
Component: user interface Version: 2.6p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

When receiving HTML enriched mails, URLs get cut at pipe symbol. This leads them to wrong pages.

Steps to reproduce

  1. Open an HTML enriched mail and look for pipe symbols within URLs.
  2. See that the whole string after opening "<" upto "|" is marked in URL clickable colour.
  3. See that beginning from "|" symbol to the closing ">" the text colour changes to normal, thus making the URL invalid and generating wrong URLs when double clicked.

Expected results

Accept pipe symbol "|" as being part of URL. OpenURL is able to handle that, just YAM is not. Call the URL from Shell or paste it to any messenger that supports OpenURL to see that it works.

Actual results

Within URL strings, YAM changes text colour on certain characters such as pipe "|". Others may be a problem, too. YAM only sends the first part to OpenURL which in most cases is invalid, at least not the URL that you wanted to open.

Regression

Have to mark, copy, paste the URL, manually start web browser and enter URL from clipboard into URL textfield gadget, hit Return key instead of one simple double-click.

Notes

URL on request because I don't want to paste any commercials here.
YAM 2.6p1 [MOS/PPC] on MorphOS 2.7.

Attachments (3)

Software_des_Jahres_-_Gewinner_im_Doppelpack!.msg (22.7 KB) - added by Sprocki 3 years ago.
example message that causes YAM to misinterpret URLs due to pipe symbol
Grab.png (90.2 KB) - added by Sprocki 3 years ago.
example screenshot
Grab2.png (73.8 KB) - added by Sprocki 3 years ago.
same mail with YAM 2.7 nightly, changeset 5750, both MOS and OS3 version

Download all attachments as: .zip

Change History (10)

comment:1 Changed 3 years ago by damato

If possible, please attach an example mail here on the ticket (use attachment functionality) with the respective URL so that we can investigate the issue more deeply.

Changed 3 years ago by Sprocki

example message that causes YAM to misinterpret URLs due to pipe symbol

comment:2 Changed 3 years ago by damato

  • Status changed from new to pending

Sorry, but I am still not able to reproduce the issue. Here I have imported the attached mail, but the only link in that mail is a mailto: linke to the email address of that spammer. Here I do have the html2text conversion routines active thus all the HTML stuff is mostly stripped to keep the text partly readable. However, I also tried to switch off the html2text engine and still all the links with pipe symbols still show up properly highlighted.

Changed 3 years ago by Sprocki

example screenshot

comment:3 Changed 3 years ago by Sprocki

  • Status changed from pending to new

Attachment (Grab.png) added by ticket reporter.

comment:4 Changed 3 years ago by damato

  • Component changed from charset handling to user interface
  • Milestone set to YAM 2.7
  • Resolution set to duplicate
  • Status changed from new to closed

Ok. Thanks for the attached image, now I can see the difference. However, the issue seems to be already fixed in changeset [5650], thus the latest nightly build (2.7-dev) as well as the upcoming 2.7 release will have that issue fixed. Thanks anyway for the nice report. I'll flag it as a duplicate of ticket #254 as that is were the issue with non matching URLs were already reported and tracked.

Changed 3 years ago by Sprocki

same mail with YAM 2.7 nightly, changeset 5750, both MOS and OS3 version

comment:5 Changed 3 years ago by Sprocki

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I copied the same mail from filesystem view to a fresh nightly build (changeset 5750). For both versions, MOS and OS3, where http URLs have been I only see gaps now (see attached Grab2.png). Only mailto links appear fine, see white mail address URL. Importing any other message with simple URL structure such as http://www.4635tg45ujh.com works, so this indicated that the parsing on URLs with special characters such as Umlauts, pipe symbol and maybe others is not correct yet. Therefore I reopen the bug.

comment:6 Changed 3 years ago by damato

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [5759]) * HTML2Mail.l: reworked the main html2mail flex rules to behave somewhat more

hierarchically. Previously the rules were pretty much mixed up. Now they
should more cleanly convert a html mail (and especially embedded links)
to a somewhat more readable text. This should finally closes #279.

comment:7 Changed 3 years ago by Sprocki

Verified to work with nightly build of Dec, 16, 2011.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Markus Lunk(Reporter, Participant)