close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

#299 closed bug (fixed)

Identities/Compose mail not possible to save a Reply-To Address

Reported by: rmsyam Owned by:
Priority: normal Milestone: YAM 2.8
Component: user interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

Even when an valid e-mail address is entered in Reply-To Address and the Config is saved, after re opening the Config, this field will be empty.

Steps to reproduce

  1. enter an e-mail address in Reply-To Address
  2. Save config
  1. open Config and check, the filed will be empty

Expected results

Actual results

Regression

Notes

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by damato

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.8
  • Priority changed from undecided to normal
  • Status changed from new to accepted

First of all, thanks for the nice bug report.

After some investigating we found out that the problems seems to be related to BetterString.mcc which is used by these GUI elements. We also already found a fix for it. However, this requires to release a new BetterString.mcc version to get the problem fixed reliably.

For the time being (until this new betterstring.mcc version is released and the minimum required version in yam bumped) I will keep that bug report as "accepted".

comment:2 Changed 3 years ago by damato

(In [5901]) * mui/Recipientstring.c: updated Betterstring_mcc.h and made use of the new

MUIA_BetterString_NoNotify attribute to prevent betterstring from
sending out too many notifications for changed of MUIA_String_Contents.
This refs #299.

comment:3 Changed 3 years ago by damato

  • Resolution set to fixed
  • Status changed from accepted to closed

With the release of BetterString.mcc 11.22 and its requirement implemented in changeset [5916] the problem should be finally fixed. Please reopen this ticket if the problem persists after having installed BetterString.mcc 11.22.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter)