close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 5 years ago

Closed 4 years ago

#3 closed bug (worksforme)

Don't accept () as email delimiters

Reported by: tactica@… Owned by: somebody
Priority: low Milestone: YAM 2.7
Component: MIME handling Version: 2.5
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description (last modified by tboeckel)

If <> are the only valid email delimiters as the
comments to feature request #583703 seem to imply,
YAM shouldn't accept () in the first place when
writing an email. Currently YAM won't complain at
all if you post a message with a From: header
like "name (user@host)".


Moved from SF:
https://sourceforge.net/tracker/?func=detail&aid=1753002&group_id=13560&atid=113560

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by damato

Well, the problem is here that ( and ) are prefectly valid characters for
including in the full email address. So e.g. something like "Jens (damato)
Langner <Jens.Langner@…>" is perfectly valid and should
therefore also be allowed in YAM. However, the ( and ) chars are clear
'comment' characters and not the delimiters for seperating the email part
from the real name part. So something like "Jens Langner
(Jens.Langner@…)" is definitly wrong and violates any RFC.

So, IMO we should keep the possibility to add ( and ) to your real name.
However, YAM should never send any email with such a broken
recipient/sender adress and AFAIR it isn't possible to send such a mail
(apart from manually modifying the From: header line in the write window).
And if YAM should eventually receive such a broken email it should not try
to be smart any treat those ( ) chars as the realname<>email delimiters
instead of <> as this is calling for trouble... Broken mail are broken, and
nothing more :)


Moved from SF. Original poster: damato

comment:2 Changed 5 years ago by damato

The whole point is that YAM *does* allow to send an email
with a From: line like "Name (user@…)", literally,
at least with my mail server. And yes, I tried this by
editing this header in the Write window.

If that's illegal, YAM is only contributing to the problem,
so it should throw an error immediately.


Moved from SF. Original poster: tactica

comment:3 Changed 5 years ago by damato

Yes, you are right. YAM should not allow to send an email with such an
illegal From: and/or To: line whatsoever. So I will see how I can fix that
issue and raise an error instead. However, please note that YAm should also
make sure that it isn't possible to end up with such an address in any
automatic way. So please also check that it isn't possible to enter such an
illegal address in either the addressbook or any other GUI element in the
configuration, for example. But please keep in mind that something like
"Name (doe@…) <doe@…>" is valid even if it doesn't make sense.


Moved from SF. Original poster: damato

comment:4 Changed 5 years ago by damato

According to RFC 2282 even something like this is valid, although not
encouraged:

From: Pete(A wonderful \) chap) <pete(his account)@silly.test(his host)>
To:A Group(Some people)
:Chris Jones <c@(Chris's host.)public.example>,
joe@example.org,
John <jdoe@one.test> (my dear friend); (the end of the group)
Cc:(Empty list)(start)Undisclosed recipients :(nobody(that I know))

Text within () should be treated as (nested) comment which reduces the
examples above to something like this (if I understood the RFC correctly):

From: Pete <pete@silly.test>
To:A Group
:Chris Jones <c@public.example>,
joe@example.org,
John <jdoe@one.test>;
Cc:Undisclosed recipients :;

Hence to be on the safe side we would need another lexical analyzer to
parse/check an email address. Simply forbidding () in the address part is
not enough.


Moved from SF. Original poster: thboeckel

comment:5 Changed 5 years ago by damato

As the issue seems to require a rework of our current email address parser
routines and we are running out of time till the 2.5 release, I'll
reschedule that issue for the 2.6 release cycle.


Moved from SF. Original poster: damato

comment:6 Changed 5 years ago by damato

  • Priority changed from major to undecided
  • Severity set to major

comment:7 Changed 5 years ago by damato

  • Component changed from nightly build to undefined

comment:8 Changed 5 years ago by damato

  • Cc yamos-svn@… removed

comment:9 Changed 5 years ago by damato

  • Component changed from undefined to MIME handling
  • Milestone set to YAM 2.7
  • Priority changed from undecided to low
  • Status changed from new to accepted

We do have to check if this ticket is still valid and how we can easily fix it for the next release.

comment:10 Changed 4 years ago by tboeckel

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from accepted to closed

I just checked this ticket again with lots of variations of names and addresses with and without bracket and for me YAM either correctly rejected them as invalid or surrounded the brackets with quotes to make them part of the real name.

Hence from my point of view there is nothing to be fixed.

Closing this one as "works for me".

Feel free to reopen this ticket if YAM is doing something wrong in this respect.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • tactica@…(Reporter)