close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#302 closed bug (invalid)

Images not visible anymore in Write/Reply and Forward Windows

Reported by: rmsyam Owned by:
Priority: undecided Milestone: YAM 2.8
Component: user interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

With YAM versions as of 2012-05-12 images in Write/Reply and Forward Windows aren't shown anymore even though they are present in the "System:YAM/themes/aiss/toolbar/" drawer.

Steps to reproduce

1.
2.

Expected results

Actual results

Regression

Notes

Attachments (2)

ScreenGrab2.jpg (196.3 KB) - added by rmsyam 3 years ago.
Snoopium.log (35.8 KB) - added by rmsyam 3 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 45 years ago by rmsyam

  • Status changed from pending to new

Changed 3 years ago by rmsyam

comment:1 Changed 3 years ago by tboeckel

  • Milestone set to YAM 2.8

comment:2 Changed 3 years ago by tboeckel

  • Component changed from undefined to user interface
  • Status changed from new to pending

I just tested this on OS3 and all images are available in all windows.

Did you copy the updated .theme files and the changed image files?

comment:3 follow-up: Changed 3 years ago by rmsyam

I copied 1:1 the themes drawer from the nightly build archive to the YAM drawer just to see if it could be that. But then I get 30 errors that it could not find the "TBImages" directory. So I think it must be something else.

Adn yes, I copied the updated theme files and changed image files. I could, if it helps, send you an lha archive of the themes drawer, please let me know.

BTW I am on MorphOS, don't know if that changes anything.

comment:4 in reply to: ↑ 3 Changed 3 years ago by tboeckel

Replying to christoph.poelzl@…:

I copied 1:1 the themes drawer from the nightly build archive to the YAM drawer just to see if it could be that. But then I get 30 errors that it could not find the "TBImages" directory. So I think it must be something else.

Do you have AISS correctly installed? The install script of AISS should set up the TBIMAGES: assign.

comment:5 Changed 3 years ago by rmsyam

No AISS is not installed on my MorphOS System using the script. In fact I only use the AISS images for YAM and have them in the themes/aiss/ drawer.

comment:6 Changed 3 years ago by tboeckel

Well, the .theme file of YAM's AISS theme assumes AISS to be installed and will use the TBIMAGES: assign for that purpose. Assigning TBIMAGES: to your theme directory might work, but I really recommend to really install AISS using the script.

The images in YAM's main window are visible for you, because these are contained in the "default" theme already which each theme will fall back to, if no other replacement image is specifies in the .theme file.

In general the "default" theme and the "AISS" theme are very similar with only very few differences.

comment:7 follow-up: Changed 3 years ago by rmsyam

Ok, I understand what you are mean. Now it seems that something changed since 20120511 about themes because before it worked in all windows. Don't know what could be a good solution if one does not install AISS completely but want to use only the AISS images for YAM. Perhaps YAM could have his own images supplied with his own .theme file but this would make extra work... hmmm. On the other hand I don't understand why only in the 3 windows I mentioned it will not work anymore even that the images are present and have the correct names and path as per the .theme file, all other images are ok even in Addressbook...

comment:8 in reply to: ↑ 7 Changed 3 years ago by tboeckel

  • Resolution set to invalid
  • Status changed from new to closed

Replying to christoph.poelzl@…:

Don't know what could be a good solution if one does not install AISS completely but want to use only the AISS images for YAM.

The theme is named "AISS" and hence it requires AISS to be installed.

Perhaps YAM could have his own images supplied with his own .theme file but this would make extra work... hmmm.

Exactly this is the "default" theme. Every theme falls back to these images if the corresponding .theme file does not explicitly replace certain image with own ones.

On the other hand I don't understand why only in the 3 windows I mentioned it will not work anymore even that the images are present and have the correct names and path as per the .theme file, all other images are ok even in Addressbook...

Well, if you like to know then check with SnoopDOS what is missing.

Anyway, closing this bug as "invalid" as it was no real bug.

Changed 3 years ago by rmsyam

comment:9 follow-up: Changed 3 years ago by rmsyam

That is the point, I checked before with Snoopium and it seems that there is nothing missing! So something else seems not working correctly! I include the log, where you can see that all images are listed with "ok".

comment:10 in reply to: ↑ 9 Changed 3 years ago by tboeckel

Replying to rmsyam:

That is the point, I checked before with Snoopium and it seems that there is nothing missing! So something else seems not working correctly! I include the log, where you can see that all images are listed with "ok".

Then please provide a THEME+IMAGE debug log with your previous non-working semi AISS installation. And if possible please attach your non-working AISS theme to this ticket.

comment:11 Changed 3 years ago by rmsyam

The log is quite large, compressed 1.8 MB and also the theme drawer would exceed the max. size. Would you like it sended privatly?

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)