close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#304 closed bug (fixed)

yam produces a gr when opening config window

Reported by: MichaelMerkel Owned by:
Priority: undecided Milestone:
Component: configuration Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

I open the config window and get a GR. Continuing it does work, though.

Steps to reproduce

  1. start YAM
  2. open config window

Expected results

Actual results

Regression

Notes

grim reaper is attached.

Attachments (3)

Crashlog_YAM_2012-05-16_19-55-16.txt (39.1 KB) - added by MichaelMerkel 3 years ago.
YAM_debuglog.txt (17.3 KB) - added by MichaelMerkel 3 years ago.
Crashlog_YAM_2012-05-17_02-38-25.txt (30.2 KB) - added by padrino 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by MichaelMerkel

comment:1 Changed 3 years ago by damato

Can you please provide a 'config' debug Log generated with the debug version of yam.

Changed 3 years ago by MichaelMerkel

comment:2 Changed 3 years ago by MichaelMerkel

i just was about to create such a log - really ;-)
after putting my two little children to bed - here it is attaches.

i also should point out that i always get the "config changed" window when closing the config window. although i did not touch anything.

regards...
michael

comment:3 Changed 3 years ago by MichaelMerkel

i found the problem in my config file. seing that the log contained some errors regarding unknown smtp servers...
i have three smtp servers defined. but in my three identities only one was entered correct. the other two did simply not exist?!
i corrected this now in the config file itself and found another probelm:
the description of the servers is not persisted. i change it in the gui and save. but after restart the are lost.

regards...
michael

comment:4 follow-up: Changed 3 years ago by damato

The Problem of the smtp Description is already solved. Just wait for the next nightly Build. Also the config changed warning Thing should be fixed. But why your config had invalid entries is interesting. What exactly was Wong there? Can you please provide the Broken config?

comment:5 Changed 3 years ago by padrino

I get problems when I add an "empty ID", ie. press add and then enter nothing and save the prefs. Next time I enter them there is a GR.

Version 0, edited 3 years ago by padrino (next)

comment:6 Changed 3 years ago by padrino

YAM 2.8-dev (17.05.2012)

Don't know if this is already the mentioned "next nightly built".

Well, with this one, my prefs still GR on open with the "empty ID".

Second. you mention "config changed", still happens with this built (BTW, in German the requester should show "Abbrechen", not "Abbruch" ;))

Changed 3 years ago by padrino

comment:7 Changed 3 years ago by damato

  • Resolution set to fixed
  • Status changed from new to closed

(In [5949]) * YAM_CO.c, UserIdentity.c: added some NULL pointer checks for uin->smtpServer

and also made sure that smtpServer should always carry a valid pointer due to
setting the first active smtpServer always as the default one when creating
a new user identity via CreateNewUserIdentity(). This closes #304.

comment:8 in reply to: ↑ 4 Changed 3 years ago by MichaelMerkel

Replying to damato:

The Problem of the smtp Description is already solved. Just wait for the next nightly Build. Also the config changed warning Thing should be fixed. But why your config had invalid entries is interesting. What exactly was Wong there? Can you please provide the Broken config?

no sorry :-( just checked my backup and that one is too old. maybe i created the broken entries too early at a time it was not yet completely implemented.

regards...
michael

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Michael Merkel(Reporter, Participant)