close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 14 months ago

Last modified 14 months ago

#320 closed task (duplicate)

Remove possibility to set own folder path in each folder

Reported by: damato Owned by:
Priority: low Milestone:
Component: configuration Version:
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Phenomenon

A common failure when using YAM seems to be that users misconfigure their path settings of new custom folders so that they end up in an incorrect path setup which might delete important files, thus data.

Background analysis

The problem seems to be that users currently have the complete freedom of moving different folders to completely different root pathes by entering a complete directory path including the disk identifier. The solution for this common problem is to limit users in only entering a directory name for a folder which is always relative to the mail directory configured in the user configuration file (PROGDIR:.users)

Implementation recommendation

Care have to be taking in how the user configures the directory name in the folder configuration as it should be prevented that he enters characters which are not allowed in directory names (e.g. ':', '/', etc.). Furthermore it should be investigated if the directory could be automatically generated via the folder name if possible.

Attachments (0)

Change History (3)

comment:1 Changed 21 months ago by damato

  • Milestone changed from YAM 2.8 to YAM 2.9

comment:2 Changed 14 months ago by damato

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #222

comment:3 Changed 14 months ago by damato

  • Milestone YAM 2.9 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jens Maus(Reporter, Participant)