close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#328 closed bug (worksforme)

nightly os3 doesn't load theme images

Reported by: plokklop@… Owned by:
Priority: normal Milestone: YAM 2.8
Component: user interface Version: nightly build
Severity: minor Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Yam 2.8 [OS 3] Nightly doesn't load theme images anymore.

Last one that worked is the one from 07/05/2012. Anything after that date have blank buttons.
Copying the 'new' images over the 'old' ones doesn't work, same as copying the 'old' ones over the 'new' ones.

To reproduce, just unpack to ram: and run the program.

Tested under Winuae 2.3.3 and 2.4.2 b4 with os3.9 and updated mui.

Attachments (1)

yambug.jpg (55.8 KB) - added by plokklop@… 23 months ago.
yam showing blank buttons

Download all attachments as: .zip

Change History (8)

comment:1 follow-up: Changed 44 years ago by plokklop@…

  • Status changed from pending to new

Changed 23 months ago by plokklop@…

yam showing blank buttons

comment:1 follow-up: Changed 23 months ago by tboeckel

Which theme are you using? From your description I'd guess that you are using a third party theme and its .theme file is not updated yet.

comment:2 in reply to: ↑ 1 Changed 23 months ago by plokklop@…

Replying to thboeckel:

Which theme are you using? From your description I'd guess that you are using a third party theme and its .theme file is not updated yet.

I'm using the default theme, but the other themes supplied with yam (no third party) don't work either. As if they can't be loaded by mui anymore.
Everything worked fine with yam from 07/05/2012. When replacing this version with the new one, all the images are gone. Tried to check out if they load, with snoopdos3. Can't see much difference.

comment:3 Changed 23 months ago by tboeckel

  • Status changed from new to pending

I just downloaded the latest nightly build (11.06.2012), unpacked it to RAM: and ran it from there. Apart from the 3 usual errors (DST settings, characters set, missing .addressbook file) there is no other error and all images are displayed correctly.

Did you copy the complete "default" theme directory including the .theme file or just the image files?

comment:4 Changed 23 months ago by tboeckel

  • Milestone set to YAM 2.8
  • Priority changed from undecided to normal
  • Severity changed from major to minor

comment:5 Changed 23 months ago by plokklop@…

Did some more checking. Seems that akPNG doesn't like your versions after 07/05/12. Loading of the images with WarpPNG and os3.9 PNG works fine, except for the blank background with the os3.9 datatype. So Yam now works again. :) Did you by any change enable or change the alpha layering of the png images within mui ? This would be a logical explanation for showing the empty buttons. Maybe stripping the images from the alpha layer would help.

comment:6 Changed 23 months ago by tboeckel

  • Resolution set to worksforme
  • Status changed from new to closed

The only change I can think of is the new drafts folder image, which Martin Merz recently created for us. But then he also did all the other graphics. I don't know if there is any difference.

Of course all images use transparency and this will definitely not be deactivated.

I did my test on a WinUAE installation running OS 3.9. Here I use akPNG 45.95, which is the most recent one available on AmiNet, and have absolutely no problems.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • plokklop@…(Reporter, Participant)