close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 22 months ago

Last modified 16 months ago

#331 closed bug (duplicate)

YAM tried to open file with previous message subject as name before crashing when sending mail

Reported by: hypex Owned by:
Priority: undecided Milestone:
Component: user interface Version: 2.7
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

This is kind of complicated to explain. And it's happened enough now to annoy me. I sent one email and it was fine. The subject was "Re: MAUG meetings, 7/5/2012, 10:15 am".

I then sent another and for comparison the subjject was "Re: MAUG Amiga One Sata". I then got a file requester trying to open a file called " meetings, 7/5/2012, 10". What!? It kept coming back. I tried to assign it to RAM but you know as it always happens with those bugs assigning it doesn't work. Eventually it crashed. I attach those two emails mentioned and three crash logs. :-)

Attachments (5)

Re__MAUG_Amiga_One_Sata.eml (4.6 KB) - added by hypex 2 years ago.
Re__MAUG_meetings,_7_5_2012,_10_15_am.eml (1.4 KB) - added by hypex 2 years ago.
Crashlog_YAM_2012-07-05_00-23-38.txt (34.4 KB) - added by hypex 2 years ago.
Crashlog_YAM_2012-07-05_00-23-29.txt (34.5 KB) - added by hypex 2 years ago.
Crashlog_YAM_2012-07-05_00-25-38.txt (35.0 KB) - added by hypex 2 years ago.

Download all attachments as: .zip

Change History (12)

Changed 2 years ago by hypex

Changed 2 years ago by hypex

Changed 2 years ago by hypex

Changed 2 years ago by hypex

Changed 2 years ago by hypex

comment:1 Changed 2 years ago by tboeckel

I just tried to reproduce this issue using YAM 2.8-dev and did the following:

  1. import both mail into the outgoing folder.
  2. double click the first mail and the click the "Send later" button
  3. the same for the second mail

So far nothing crashed here, but maybe I did it wrong. Please provide a step by step instruction how to reproduce this issue using your two example mails.

comment:2 Changed 2 years ago by hypex

Hi.

What I did was reply to the first and send it off. Then I replied to the second and sent it off. And this is where YAM went funny.

So I typed up both before sending them away. But here I just repeated the procedure to myself and they were sent fine. So it looks like a rare condition which I have a habit of finding. :-)

According to the crash log something went wrong from YAM:FO_UpdateStatistics() that caused the OS to think it was opening a file. But the last entry in the crash log is a kernel routine but not a DOS routine. :-?

comment:3 Changed 2 years ago by tboeckel

If memory was trashed before by either YAM itself or any other application then the crash log might point anywhere and the last sensible location within YAM must not necessarily be the guilty one. It might just happen to occur in the crash log because the data it is was using were malformed by the trashed memory.

As long as you cannot reproduce this issue it is unlikely that this crash will be fixed.

comment:4 Changed 22 months ago by damato

  • Status changed from new to pending

I agree with thore here. As long as you cannot reproduce the problem youself we will have a hard time finding a proper fix. In addition, now that 2.8 is released, did it happen to you again?

comment:5 Changed 22 months ago by tboeckel

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.8p1
  • Resolution set to duplicate
  • Status changed from pending to closed

Please refer to #377 for updated versions of BetterString.mcc which no longer should trash memory. The effects you describe very much smell like trashed memory. Please reopen this ticket if it happens again nevertheless.

comment:6 Changed 21 months ago by hypex

Since installing 2.8 I haven't seen this. I will test BetterString.mcc and see how it goes. Hopefully the end of a buggy ride! :-)

comment:7 Changed 16 months ago by damato

  • Milestone YAM 2.8p1 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Damien Stewart(Reporter, Participant)