close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 2 years ago

#336 closed bug (fixed)

YAM crashes right at startup when geting e-mails from server

Reported by: rmsyam Owned by:
Priority: high Milestone: YAM 2.8
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

YAM crashes right at startup when geting e-mails from server. I get hits in the log. The latest working version is the one from 20120626. Used under MorphOS 3.1

Steps to reproduce

  1. start YAM 2.

Expected results

Actual results

Regression

Notes

Attachments (2)

yam.log (4.4 KB) - added by rmsyam 2 years ago.
yam_1.log (1.8 KB) - added by rmsyam 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by rmsyam

comment:1 Changed 2 years ago by damato

Please provide a debug log using the debug version of the nightly build and issue a "setenv yamdebug @all all" call before starting the debug version. Be prepared to catch a lot of debug information on the serial line and post the last few lines here please.

Changed 2 years ago by rmsyam

comment:2 follow-up: Changed 2 years ago by rmsyam

Please find attached the yam log.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 2 years ago by tboeckel

  • Milestone set to YAM 2.8

Replying to rmsyam:

Please find attached the yam log.

Ask you should have noticed yourself this in an incomplete log. Does your machine freeze hard? I am affraid we cannot help you with such a crippled log. Please try to provide a complete one.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 2 years ago by rmsyam

Replying to thboeckel:

Replying to rmsyam:

Please find attached the yam log.

Ask you should have noticed yourself this in an incomplete log. Does your machine freeze hard? I am affraid we cannot help you with such a crippled log. Please try to provide a complete one.

No it's not the machine that freezes but YAM. I can provide a complete log but even lha compressed it's 2.5 MB, no compression it's 45 MB. Can I send it privatly?

comment:5 in reply to: ↑ 4 Changed 2 years ago by tboeckel

Replying to rmsyam:

No it's not the machine that freezes but YAM. I can provide a complete log but even lha compressed it's 2.5 MB, no compression it's 45 MB. Can I send it privatly?

Of course it is at least YAM that is freezing due to the crash :)

I just asked because the log you attached somehow got "cut" in the middle of a line which typically indicates a fully frozen machine.

However, please go ahead and send the log to us in private. Without it this bug cannot be fixed.

comment:6 Changed 2 years ago by tboeckel

  • Priority changed from undecided to high
  • Resolution set to fixed
  • Status changed from new to closed

After lots of tests by Christoph Pölzl this bug is finally fixed. Thanks a lot Christoph!

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)