close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#344 closed bug (fixed)

No content in Error messages window, it's empty

Reported by: rmsyam Owned by:
Priority: undecided Milestone: YAM 2.8
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

If an error occurs and the Error message window comes up, it's empty, there is not content in the window.

Steps to reproduce

1.
2.

Expected results

Actual results

Regression

Notes

Attachments (2)

ScreenGrab.png (1.1 MB) - added by rmsyam 2 years ago.
yam.log (19.6 KB) - added by rmsyam 2 years ago.

Download all attachments as: .zip

Change History (13)

Changed 2 years ago by rmsyam

comment:1 follow-up: Changed 2 years ago by tboeckel

I just logged into web.de too early again (there is a time limit of 15 minutes) and got a perfectly readable error message. Does this happen in certain situations only for you? From the screeshot I can see that you were writing a new mail. Perhaps this is specific to this situation only.

comment:2 Changed 2 years ago by tboeckel

  • Milestone set to YAM 2.8

comment:3 in reply to: ↑ 1 ; follow-up: Changed 2 years ago by rmsyam

Replying to thboeckel:

I just logged into web.de too early again (there is a time limit of 15 minutes) and got a perfectly readable error message. Does this happen in certain situations only for you? From the screeshot I can see that you were writing a new mail. Perhaps this is specific to this situation only.

Well yes/no... yes I was writing a new mail and the error messages window poped up because I selected forward a message and YAM complained. For now I can confirm that the error messages window is empty in this situation and also when for example YAM couldn't connect to the mail server. To me I rather think it's not a specific situation but global. Could you tell me how I could test this in several situations?

comment:4 in reply to: ↑ 3 ; follow-up: Changed 2 years ago by tboeckel

Replying to rmsyam:

Well yes/no... yes I was writing a new mail and the error messages window poped up because I selected forward a message and YAM complained. For now I can confirm that the error messages window is empty in this situation and also when for example YAM couldn't connect to the mail server. To me I rather think it's not a specific situation but global. Could you tell me how I could test this in several situations?

Could please state exactly what you did in which sequence. So far I was not able to reproduce this issue my self, no matter how many mails I replied to.

For the case that an error message is triggered when trying to connect to a server please provide a simple "net" log. This will include any error messages produced by the threads.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 2 years ago by rmsyam

Replying to thboeckel:

Replying to rmsyam:

Well yes/no... yes I was writing a new mail and the error messages window poped up because I selected forward a message and YAM complained. For now I can confirm that the error messages window is empty in this situation and also when for example YAM couldn't connect to the mail server. To me I rather think it's not a specific situation but global. Could you tell me how I could test this in several situations?

Could please state exactly what you did in which sequence. So far I was not able to reproduce this issue my self, no matter how many mails I replied to.

For the case that an error message is triggered when trying to connect to a server please provide a simple "net" log. This will include any error messages produced by the threads.

Just to make sure that I explained it correctely: it goes only here that the Error messages window is empty, there is no content which is displayed in this window. So if an error occured, I can't see what it caused because the window is empty.

I give you an example here: sometimes when YAM could not connect for whatever reason to the mailserver to get mails, then the Error messages window pops up. but it is empty instead of it's stated that YAM could not retreive the mails because it could not connect to the mailserver.

I hope I was clear enough, otherwise please let me know.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 2 years ago by tboeckel

Replying to rmsyam:

I give you an example here: sometimes when YAM could not connect for whatever reason to the mailserver to get mails, then the Error messages window pops up. but it is empty instead of it's stated that YAM could not retreive the mails because it could not connect to the mailserver.

This is the reason why I was asking for a "net" log. Apart from the usual network traffic such a log also includes error messages from a thread long before it is finally shown (visible or invisible) in the error window.

Changed 2 years ago by rmsyam

comment:7 in reply to: ↑ 6 ; follow-up: Changed 2 years ago by rmsyam

Replying to thboeckel:

Replying to rmsyam:

I give you an example here: sometimes when YAM could not connect for whatever reason to the mailserver to get mails, then the Error messages window pops up. but it is empty instead of it's stated that YAM could not retreive the mails because it could not connect to the mailserver.

This is the reason why I was asking for a "net" log. Apart from the usual network traffic such a log also includes error messages from a thread long before it is finally shown (visible or invisible) in the error window.

Please find attached the netlog logfile.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 2 years ago by tboeckel

Replying to rmsyam:

Please find attached the netlog logfile.

Did you get an empty error message during this run? All I can see is that there were no messages to download on the server, but this should not cause any errors.

comment:9 in reply to: ↑ 8 Changed 2 years ago by rmsyam

Replying to thboeckel:

Replying to rmsyam:

Please find attached the netlog logfile.

Did you get an empty error message during this run? All I can see is that there were no messages to download on the server, but this should not cause any errors.

No I didn't, no errors! I mentioned such an example only to explain that when an Error messages window opens the error is not shown, or perhaps invisible.

comment:10 Changed 2 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [6202]) * YAM_ER.c: reworked the handling of overflowed error messages added some debug output in case setting up the final error message fails.

Reported as having been fixed by Christoph Pölzl.

comment:11 Changed 2 years ago by tboeckel

(In [6213]) * YAM_ER.c: don't rely on MUI's notifications to (re)display the current message as it seems MUI4 on MorphOS does not trigger the notification under the same circumstances as MUI3 does anymore.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter, Participant)