close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 2 years ago

#345 closed bug (fixed)

Forward complains that there is no message to forward

Reported by: rmsyam Owned by: tboeckel
Priority: undecided Milestone: YAM 2.8
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

When selecting forward, YAM complains that there is no message to forward even though the message is listed in the attachments section of the write window. I have to delete this entry and add it again.

Steps to reproduce

  1. Select forward a message
  2. While writing the message, as soon as the message gets saved in "Drafts" the error messages window comes up

Expected results

Actual results

Regression

Notes

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by tboeckel

  • Milestone set to YAM 2.8
  • Owner set to tboeckel
  • Status changed from new to assigned

I was just able to reproduce this myself. The reason is quite simple. When forwarding a mail YAM will remember this process to be able to display a mail a having been forwarded by renaming the corresponding mail file. However, forwarding a mail as an attachment will attach the file before renaming it. Hence YAM cannot access the file with the old name anymore and (in)correctly shows an error message.

I will see what I can do about that.

comment:2 Changed 2 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6189]) * mui/WriteWindow.c: saving a draft mail will not set the "forwarded" flag of forwarded mails as this changes the file name and makes the original mail file inaccessible when eventually saving the outgoing mail. This closes #345.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Reporter)
  • Thore Böckelmann(Owner, Participant)