close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 2 years ago

#346 closed bug (fixed)

Processor 100% creating interface

Reported by: paraphonista@… Owned by:
Priority: undecided Milestone: YAM 2.8
Component: undefined Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

Since july, YAM doesn't load anymore. It goes up to Creating interface, then processor time goes 100% and nothing happens.
I did some experiments. The last working version is the one dated 16 july (I have to change the system-time in order to use it).
BUT, if I install more recents copies over it AFTER having used it once, the more recent versions WORK. BUT if I reboot, they stop working.
I jump to the conclusion, that the working version calls for some function that stays resident in memory and still works for the other versions who dont call for it anymore, because they find it already in memory, but if I reboot, they don't find it anymore and load a not working version instead.
That's all I can say

Steps to reproduce

1.
2.

Expected results

Actual results

Regression

Notes

Here on A1XE with AOS4 update 4

Attachments (1)

logfile.txt (250.1 KB) - added by paraphonista@… 2 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 2 years ago by tboeckel

  • Milestone set to YAM 2.8

comment:2 Changed 2 years ago by tboeckel

We need an "@all,all" debug log produced with the debug version of YAM. Please refer to the FAQ for details.

Please call "setenv yamdebug @all,all,file:ram:t/yam.log.txt" before running the debug version of YAM. As the "@all" log will become quite large it may be a good idea to use a different path than "ram:t/yam.log.txt" for the log file.

In case the compressed log file should to too large to be attached to this ticket we don't mind if you send to log to us via private EMail.

Changed 2 years ago by paraphonista@…

comment:3 Changed 2 years ago by tboeckel

Thanks for the log. It seems YAM is misinterpreting the layout string in the wrong way which then in turn causes the freeze. This should be fixed in the next nightly build. Please check again with that version.

comment:4 Changed 2 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [6242]) * YAM_UT.c: slightly changed the recognition of old and new layout strings and added some debug output. This closes #346.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • paraphonista@…(Reporter)