close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#347 closed bug (duplicate)

Crash after deleting an incoming message

Reported by: JosDuchIt Owned by: damato
Priority: normal Milestone: YAM 2.8
Component: MIME handling Version: 2.7
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

Domtimes after a first delete of a message, somtimes after the 2nd or 3d delete in the incoming folder, YAM will crash

Steps to reproduce

  1. Delete an incoming message
  2. If not a crashe repeat 1

Expected results

Actual results

Regression

Notes

Attachments (4)

Crashlog_YAM.debug_2012-09-24_10-28-52.txt (28.3 KB) - added by JosDuchIt 19 months ago.
Crash after a first delete
Crashlog_YAM.debug_2012-09-24_10-23-40.txt (30.7 KB) - added by JosDuchIt 19 months ago.
crash after previous succesfull deletes
QVZaAgACXTo=.001,R (12.8 KB) - added by tboeckel 19 months ago.
Crashing mail as sent by JosDuchIt
Crashlog_YAM.debug_2012-09-26_08-14-16.txt (29.4 KB) - added by tboeckel 19 months ago.
Crashlog for crashing mail

Download all attachments as: .zip

Change History (11)

Changed 19 months ago by JosDuchIt

Crash after a first delete

Changed 19 months ago by JosDuchIt

crash after previous succesfull deletes

comment:1 follow-up: Changed 19 months ago by damato

After shortly having looked at the crashlogs you attached I think the problem might be in the HTML conversion routines to display HTML mails as plain text. However, to further investigate could you please provide the raw mail file of the HTML mail that is causing these crashes? That would definitely help.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 19 months ago by JosDuchIt

Replying to damato:

After shortly having looked at the crashlogs you attached I think the problem might be in the HTML conversion routines to display HTML mails as plain text. However, to further investigate could you please provide the raw mail file of the HTML mail that is causing these crashes? That would definitely help.

I do not see how i can attach the mail file to this reply.

As after a delete the file is in the "trash" folder and this is emptied when i restart Yam, the easiest way for me is to select 'continue' after i did write a crashlog with Grimreaper and to forward the 'deleted message' I did this, but did send the message to Thore, also with the raw fmessage attached. Can you contact me by mail ?

Changed 19 months ago by tboeckel

Crashing mail as sent by JosDuchIt

Changed 19 months ago by tboeckel

Crashlog for crashing mail

comment:3 in reply to: ↑ 2 Changed 19 months ago by tboeckel

Replying to JosDuchIt:

As after a delete the file is in the "trash" folder and this is emptied when i restart Yam, the easiest way for me is to select 'continue' after i did write a crashlog with Grimreaper and to forward the 'deleted message' I did this, but did send the message to Thore, also with the raw fmessage attached.

I just attached the mail and the crashlog.

And the solution to your "trash" problem is very simple: don't empty the trash folder when starting YAM. Additionally the mail you sent to me is still in your "Sent" folder. You see, there are lots of ways to not loose such a mail.

comment:4 follow-up: Changed 19 months ago by damato

  • Component changed from undefined to MIME handling
  • Milestone set to YAM 2.8
  • Owner set to damato
  • Priority changed from undecided to normal
  • Status changed from new to assigned

comment:5 in reply to: ↑ 4 ; follow-up: Changed 19 months ago by JosDuchIt

Replying to damato:
@Thore
Thanks for uploading my 'crash' message
Attach files here:
OK i discoverd how you can attach a file to a message here. I did not see that in fact all files uploaded are linked together in a common "attachments" view, with an upload (attach file) button.
My impression was that, after pressing the "attachments" button below the message, i just got some upwards shift of the ticket page, while i was expecting a file requester to appear.
Looking bettter, i do see the little up arrow now, next to it.

Trash problem: the doc states:
›Trash›

This box contains messages marked for deletion. Normally messages
are not actually deleted from the hard disk until you quit YAM.
This allows you to recover messages deleted earlier in the session.

I don't see a settings to overrule this. Is there? If not, might be a suggestion

comment:6 in reply to: ↑ 5 Changed 19 months ago by damato

Replying to JosDuchIt:

Trash problem: the doc states:
›Trash›

This box contains messages marked for deletion. Normally messages
are not actually deleted from the hard disk until you quit YAM.
This allows you to recover messages deleted earlier in the session.

I don't see a settings to overrule this. Is there? If not, might be a suggestion

There should be some checkboxes in the "Start/Quit" configuration pane in yam where you can then define at which step you want yam to automatically empty your trash. if you unselect both checkboxes yam should never automatically cleanup your trash , thus you have to manually clean it.

comment:7 Changed 19 months ago by damato

  • Resolution set to duplicate
  • Status changed from assigned to closed

According to the crashlog this is essentially the same like ticket #348. Thus I close this ticket as being a duplicate of that. So please continue to discuss this issue there instead.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jens Maus(Owner, Participant)
  • Joseph Duchâtelet(Reporter, Participant)