close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 23 months ago

#348 closed bug (fixed)

Systematic Crash when trying to a message

Reported by: JosDuchIt Owned by: damato
Priority: normal Milestone: YAM 2.8
Component: MIME handling Version: nightly build
Severity: major Keywords:
Cc: padrino OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

  • The message attached could not be opened without producing a crash - Crashlog attached
  • While this message was the last one in the incoming drawer,Yam crashed when it was loaaded. This happened after a warm & after a cold reboot - cashlog attached

Steps to reproduce

1.
2.

Expected results

Actual results

Regression

Notes

Attachments (10)

Crashlog_YAM.debug_2012-09-28_13-46-16.txt (28.7 KB) - added by JosDuchIt 2 years ago.
Crashlog_YAM.debug_2012-09-28_13-50-10.txt (27.6 KB) - added by JosDuchIt 2 years ago.
QVlaPgAMHC8=.001,R (9.3 KB) - added by JosDuchIt 2 years ago.
Crashlog_YAM.debug_2012-09-28_19-16-38.txt (28.6 KB) - added by JosDuchIt 2 years ago.
QVmjCQANJf0=.001,R (7.2 KB) - added by JosDuchIt 2 years ago.
Crashlog_YAM.debug_2012-09-29_09-45-13.txt (28.7 KB) - added by JosDuchIt 2 years ago.
Crashlog when opening next Message
QVp1ogANZfw=.001,R (3.2 KB) - added by JosDuchIt 2 years ago.
Meesage that crashes when opening
YAM_os4_gcc424.lha (875.3 KB) - added by tboeckel 23 months ago.
YAM (AmigaOS4) built with gcc 4.2.4
Crashlog_yam.OS4_2012-10-10_14-21-34.txt (24.3 KB) - added by JosDuchIt 23 months ago.
crash when opening (initial window appears)
YAM_os4_gcc471_20121010.lha (899.4 KB) - added by tboeckel 23 months ago.
yet another build done with gcc 4.7.1

Download all attachments as: .zip

Change History (36)

comment:1 Changed 45 years ago by JosDuchIt

  • Status changed from pending to new

Changed 2 years ago by JosDuchIt

Changed 2 years ago by JosDuchIt

comment:1 Changed 2 years ago by damato

Hi, first of all please attach the raw mail file also to this ticket. Second, you are stating that you are using YAM 2.7. Would you please be so kind in trying to use one of the latest 2.8-dev nightly build versions to see if the problem still exists?

Changed 2 years ago by JosDuchIt

comment:2 Changed 2 years ago by JosDuchIt

I was using Yam-debug 2.8dev 9/20/2012 for the report & attachments
You may be mislead by the fact that i use this debug version or alternatively the 2.7 normal version from the same drawer named YAM_2.7

(In fact I don't have the problem with the 2.7 version)

Last edited 2 years ago by JosDuchIt (previous) (diff)

Changed 2 years ago by JosDuchIt

Changed 2 years ago by JosDuchIt

comment:3 Changed 2 years ago by JosDuchIt

I added a crashlog & the raw message of a new one crashing too when opened

comment:4 Changed 2 years ago by JosDuchIt

Downloaded the latest 22 / 09 debug version
The crash is still there with the same (last message)
I guess you don't need a new crashlog?

Changed 2 years ago by JosDuchIt

Crashlog when opening next Message

Changed 2 years ago by JosDuchIt

Meesage that crashes when opening

comment:5 Changed 2 years ago by JosDuchIt

The last message & its crashlog are for YAM-debug 2.8dev 22/09/12

comment:6 Changed 2 years ago by damato

  • Component changed from undefined to MIME handling
  • Milestone set to YAM 2.8
  • Owner set to damato
  • Priority changed from undecided to normal
  • Status changed from new to assigned
  • Version changed from 2.7 to nightly build

can you please download the version from Augut, 29th and try to reproduce the problem with that version please?

The download link to this older version is:

http://nightly.yam.ch/2012-08-29-dev/YAM28dev-AmigaOS4.lha

then please simply report of this version crashes also or not?

comment:7 Changed 2 years ago by JosDuchIt

I can not run that version: i am told that it is obsolete and have to use a newer version.
What should i do?

comment:8 Changed 23 months ago by damato

  • Status changed from assigned to pending

I just tried today to reproduce the crash with the mails you have attached to this ticket. However, I wasn't able to reproduce it and here all the three emails display nicely in the texteditor and without showing any crash. Can you please try to reproduce the problem with the latest nightly build. In addition, please give some more information about the system your are using when you try to reproduce the problem. Furthermore it would help if you could also try to reproduce the problem with the debug version of the nightly build.

So sorry, I can't reproduce the problem , thus we need some more help from you to understand the root of your crashes.

comment:9 Changed 23 months ago by JosDuchIt

I downloaded & installed the latest debug version.
Please note that all my reports were done using a debug-version, and if not otherwise instructed i'll continue tot do this.

My system is a Sam 440ep with OS4.1 Updt 5

The problem is still there and ocurs when i do set the settings /Read/ convert html e-mails to plain text.
If i don't use that i have no crash but the html tags are all visible

comment:10 follow-up: Changed 23 months ago by damato

Thats strange. He i tried the same but there are no crashes. Thore, can you reproduce this problem?
Jos, are you also uptodate with all the mcc classes? Furthrmore it would perhaps also help if you could attach your config file to this ticket. However, please make sure to strip private information first (e.g. Passwords)

comment:11 in reply to: ↑ 10 ; follow-up: Changed 23 months ago by tboeckel

Replying to damato:

Thore, can you reproduce this problem?

Unfortunately not, but I tried with the AmigaOS3 build only. Maybe this crash is due to the recent change to GCC 4.7.1? The AmigaOS3 build is done with the ancient GCC 2.95.3 and for AmigaOS4 I am still using GCC 4.2.4.

comment:12 in reply to: ↑ 11 ; follow-up: Changed 23 months ago by damato

Replying to thboeckel:

Replying to damato:

Thore, can you reproduce this problem?

Unfortunately not, but I tried with the AmigaOS3 build only. Maybe this crash is due to the recent change to GCC 4.7.1? The AmigaOS3 build is done with the ancient GCC 2.95.3 and for AmigaOS4 I am still using GCC 4.2.4.

Well, I also thought about that but as I said, I can't reproduce the problem here on my AOne. Also the GCC 4.7.1 compiled version does not crash. But perhaps it would be greate if you could compile a version with the older GCC 4.2.4 and send it to Joseph so that he could test this version instead.

Changed 23 months ago by tboeckel

YAM (AmigaOS4) built with gcc 4.2.4

comment:13 in reply to: ↑ 12 Changed 23 months ago by tboeckel

Replying to damato:

Well, I also thought about that but as I said, I can't reproduce the problem here on my AOne. Also the GCC 4.7.1 compiled version does not crash. But perhaps it would be greate if you could compile a version with the older GCC 4.2.4 and send it to Joseph so that he could test this version instead.

Done. Joseph, please try the gcc 4.2.4 build and tell us if that is crashing as well or not.

comment:14 follow-up: Changed 23 months ago by JosDuchIt

I tried the ggcc4.2.4 build and it does not crash when the settings is put to "convert to plain text"
When the settings is not set i see the same message with all the html tags

comment:15 in reply to: ↑ 14 ; follow-up: Changed 23 months ago by tboeckel

Replying to JosDuchIt:

I tried the ggcc4.2.4 build and it does not crash when the settings is put to "convert to plain text"
When the settings is not set i see the same message with all the html tags

We have a compiler issue then here which obviously affects the 440 CPU only, but not the G4 CPU in Jens' AmigaOne.

Jens, what suits you best? Reverting to gcc 4.5.x or fixing this bug in gcc 4.7.x?

comment:16 in reply to: ↑ 15 ; follow-up: Changed 23 months ago by damato

Replying to thboeckel:

Replying to JosDuchIt:

I tried the ggcc4.2.4 build and it does not crash when the settings is put to "convert to plain text"
When the settings is not set i see the same message with all the html tags

We have a compiler issue then here which obviously affects the 440 CPU only, but not the G4 CPU in Jens' AmigaOne.

Jens, what suits you best? Reverting to gcc 4.5.x or fixing this bug in gcc 4.7.x?

Well, one case is no case I would say. So lets first find other people having the same problem. So we should contact other people with a SAM and AOne and see if they could reproduce the problem or not. Then we should investigate where exactly the crash happens and find out if tuning the compiler optimization settings might remove the problem. I doubt that this is a bug in gcc 4.7.1 but perhaps a bug in the code produced by flex which only shows up when using gcc 4.7.1. gcc itself is so widely used that I really doubt that it is buggy without other people (non-amiga users) noticing the problem.

comment:17 Changed 23 months ago by JosDuchIt

So lets first find other people having the same problem. So we should contact other people with a SAM and AOne and see if they could reproduce the problem or not.

use www.Amigans.net forum maybe?

comment:18 Changed 23 months ago by damato

  • Cc padrino added

I'll add padrino to this ticket as he should have a SAM as well and may help us in trying to reproduce the crash you are reporting here. Padrino, can you please investigate in trying the latest nightly build together with the mails JosDuchIt attached?

comment:19 in reply to: ↑ 16 Changed 23 months ago by tboeckel

Replying to damato:

I doubt that this is a bug in gcc 4.7.1 but perhaps a bug in the code produced by flex which only shows up when using gcc 4.7.1. gcc itself is so widely used that I really doubt that it is buggy without other people (non-amiga users) noticing the problem.

I just successfully imported the 3 attached mails using the latest official nightly build (gcc 4.7.1) on my MicroA1 (750FX CPU) and can also successfully view these mails with HTML to text conversion activated. So this more and more smells like an issue with the 440 (maybe 460) CPUs only.

comment:20 Changed 23 months ago by tboeckel

I just had a second look at the provided crash logs and it seems the crash is quite simple to avoid, even if it does not happen on every system. The log points to this assembler mnemonic "lwz r9,0(r9)" with r9 having the value 0xfffffffc. Thus it is obvious that this crashes, because this is an invalid address.

The HTML conversion function calls the causing function yy_top_state() just to avoid compiler warnings about an unused function. But that function accesses a pointer without verifying that this pointer is really valid.

I will build a new version which will avoid this call without causing further warnings.

comment:21 Changed 23 months ago by tboeckel

Joseph, please try the (hopefully) fixed version. Although I cannot verify it myself I am pretty sure this crash is fixed now.

Changed 23 months ago by JosDuchIt

crash when opening (initial window appears)

comment:22 follow-up: Changed 23 months ago by JosDuchIt

I tried out your attached version.
Alas it cashes when loading: the initial warning window shows up, but a crash appears as soon as i hit the ok button
Crashlog added

Changed 23 months ago by tboeckel

yet another build done with gcc 4.7.1

comment:23 in reply to: ↑ 22 Changed 23 months ago by tboeckel

Replying to JosDuchIt:

I tried out your attached version.
Alas it cashes when loading: the initial warning window shows up, but a crash appears as soon as i hit the ok button
Crashlog added

Something went wrong there during the build. Please try again with the most recent version attach. I just rebuilt YAM from scratch and replaced the previous versions.

comment:24 follow-up: Changed 23 months ago by JosDuchIt

Works OK here.

Thanks & congratulations

comment:25 in reply to: ↑ 24 Changed 23 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

Replying to JosDuchIt:

Works OK here.

That's great to hear! Closing this ticket then.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Jens Maus(Owner, Participant)
  • Joseph Duchâtelet(Reporter, Participant)
  • Mario Cattaneo(Subscriber)