close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#349 closed bug (fixed)

Attached files are broken

Reported by: fernandez_jesus@… Owned by:
Priority: normal Milestone: YAM 2.8
Component: MIME handling Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Summary

With the last version 2-8-dev-20120922 (I tested with previous nightly builds too), I have this problem.
If I save the attached files to disk or if I click on it when it is an image, I have an error.

Steps to reproduce

  1. I sent to myself some attached files. 2.

Expected results

The possibility of reading the files.

Actual results

The files are broken. For example, the size of an image is reduced from 68k to 4k.
A simple gif : 4k to 7b
An lha archive : 300k to 32k

Regression

Notes

With older nightly build versions (June 2012) and YAM 2.7, this error didn't/doesn't exist.

Attachments (2)

Attach.lha (143.3 KB) - added by fernandez_jesus@… 2 years ago.
A lha containing the raw message with the broken file and its original version
debuglog.txt (39.3 KB) - added by fernandez_jesus@… 2 years ago.
Debug with mail and mime options

Download all attachments as: .zip

Change History (7)

comment:1 Changed 2 years ago by tboeckel

Please attach some example files and the generated raw mail files.

I just sent a JPEG image to myself and was able to view it from the received mail without problems.

Changed 2 years ago by fernandez_jesus@…

A lha containing the raw message with the broken file and its original version

comment:2 follow-up: Changed 2 years ago by tboeckel

  • Milestone set to YAM 2.8

For me viewing the image works without problems, both by double clicking the attachment icon and by viewing the saved attachment directly.

Please create a "MAIL,MIME" log using the debug version of YAM and attach it to this ticket. There must be something special with your system since I cannot reproduce this issue. Refer to the FAQ for details about YAM's debugging facilities.

Changed 2 years ago by fernandez_jesus@…

Debug with mail and mime options

comment:3 in reply to: ↑ 2 Changed 2 years ago by anonymous

I have just the debug log with mail and mime options.
What I did is
1- I launched yam.debug
2- I selected the test email.
3- then I click on the attachment (one jpg file). -> Error message from multiview.
4- Save the file to ram:
5- Close YAM.

comment:4 Changed 23 months ago by tboeckel

  • Component changed from undefined to MIME handling
  • Priority changed from undecided to normal
  • Resolution set to invalid
  • Status changed from new to closed

It seems you have the "Auto-detect cyrillic charsets" option active on the Read page of YAM's config window? If yes, then please deactivate it. This option is really necessary if and only if you are using the cyrillic charset yourself (i.e. you write mails in russian). Otherwise this options should always be off.

At least with this option active while using "ISO-8859-1+Euro" as read charset I was able to reproduce this issue.

Closing this bug as invalid.

comment:5 Changed 23 months ago by tboeckel

  • Resolution changed from invalid to fixed

(In [6285]) * YAM_RE.c, mime/base64.c, mime/qprintable.c, mime/uucode.c: having the option "automatic cyrillic charset detection" active even without the necessitiy to have to use cyrillic characters will no longer screw up encoded non-text attachments. This closes #349.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • fernandez_jesus@…(Reporter)