close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#360 closed bug (fixed)

YAM just "auto completes" and jumps to text area

Reported by: padrino Owned by:
Priority: normal Milestone: YAM 2.8
Component: user interface Version: nightly build
Severity: trivial Keywords:
Cc: rmsyam OS Platform:
Blocked By: Blocking:
Release Notes:

Description

I just have to have the crsr sitting in the to: field or in the subject one and after a while YAM will jump to the text area by itself.

In both cases the GUI debug output is the same, file attached.

Attachments (1)

sashimi.out (693 bytes) - added by padrino 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by padrino

comment:1 Changed 2 years ago by tboeckel

I just encountered this myself and it seems to happen when YAM autosaves the mail to the drafts folder. Does this match your observations?

comment:2 Changed 2 years ago by tboeckel

Ok, I think I solved this faster than expected...

comment:3 Changed 2 years ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [6442]) * mui/WriteWindow.c: don't trigger any notifications when setting the write window's active page while saving the mail to the Drafts or Outgoing folder as this would change the active object. This is quite annoying if one was still typing the subject and YAM suddently activates the mail editor. This closes #360.

comment:4 Changed 2 years ago by tboeckel

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.8
  • Priority changed from undecided to normal
  • Severity changed from major to trivial

comment:5 Changed 2 years ago by rmsyam

With the latest changement, the content of the Subject gets deleted. This could happen when YAM saves to the Drafts folder, but I'm not sure.

comment:6 Changed 2 years ago by tboeckel

  • Cc rmsyam added

I anybody else still experiencing this second issue? Personally I cannot reproduce it.

comment:7 Changed 2 years ago by padrino

I see no problem here :/

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Christoph Pölzl(Subscriber, Participant)
  • Mario Cattaneo(Reporter, Participant)