close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 4 years ago

Last modified 2 years ago

#37 accepted enhancement

Support of IMAP4

Reported by: anonymous Owned by:
Priority: high Milestone: YAM 3.0
Component: TCP/IP interface Version:
Severity: major Keywords:
Cc: OS Platform:
Blocked By: 120 Blocking:
Release Notes:

Attachments (0)

Change History (16)

comment:1 Changed 4 years ago by damato

Yes, please implement IMAP4 support. Can't use YAM anymore due to lacking IMAP4 support =(


Moved from SF. Original poster: anonymous

comment:2 Changed 4 years ago by damato

I would also like to join up in the request for IMAP4 support, since this is what I use for my primary Email account and this is a very important feature in my eyes.


Moved from SF. Original poster: juzz

comment:3 Changed 4 years ago by damato

I agree. When I switched to IMAP4 I was forced to leave YAM, which was my favourite, behind in favour of various webmail solutions and graphical Linux clients such as Sylpheed. If YAM would get IMAP4 support I would most likely start using it again as my main client.


Moved from SF. Original poster: anonymous

comment:4 Changed 4 years ago by damato

I also like to see IMAP support in YAM.


Moved from SF. Original poster: anonymous

comment:5 Changed 4 years ago by damato

Is there IMAP planed for Yam2.5 at all?


Moved from SF. Original poster: anonymous

comment:6 Changed 4 years ago by damato

Simple answer: no

IMAP support is planned for 2.6, as this will require major changes.


Moved from SF. Original poster: thboeckel

comment:7 Changed 4 years ago by damato

Great, I do also need IMAP support. I liked YAM very much and did use it until 2004. Then I switched over to the web.de webinterface and did use more and more linux. Now I have a DENEB USB Controller and like to use my amiga more. But AmiSSL with Aweb is too slow. So I have to use a mail program. But I do have to much emails and don't want to download them. So IMAP will really be a great help. Thank you for planing it for version 2.6


Moved from SF. Original poster: amiga4000

comment:8 Changed 4 years ago by damato

  • Priority changed from major to undecided
  • Severity set to major

comment:9 Changed 4 years ago by damato

  • Component changed from stable build to undefined

comment:10 Changed 4 years ago by damato

  • Cc yamos-svn@… removed

comment:11 Changed 4 years ago by damato

  • Blocked By 120 added
  • Component changed from undefined to TCP/IP interface
  • Milestone set to YAM 2.7
  • Owner changed from somebody to damato
  • Priority changed from undecided to high
  • Status changed from new to accepted

Since several years it has been one of the major goal to get IMAP4 support into YAM. However, as the protocol is quite complex and requires substantial changes to YAM this hasn't been achieved yet. However, by accepting this request it should be made clear that it is our goal to get that going.

Reference to the corresponding RFC: http://www.ietf.org/rfc/rfc2060.txt

comment:12 Changed 4 years ago by damato

  • Owner damato deleted

comment:13 Changed 4 years ago by nightVzn

I know I'm just one of many people in a rather vociferous chorus, but I wanted to join in and say that IMAP support is long overdue and much needed. I have an extensive archive of e-mails on my Amiga which I'd like to be able to access with Thunderbird on my Windows machine. They've been waiting there for almost 7 years, since my provider at the time switched to IMAP. Actually that was one of the final events that pushed me to switch to my Windows box as my main computer.

But also, thank you so much for continuing to support AmigaOS 3.x, and I really, really, REALLY hope that whatever forthcoming version of YAM which finally supports IMAP continues to run on AmigaOS 3.x. I'd be heartbroken if I waited all this time for IMAP only to find that I missed out because my Amiga is 68k-only. It seems all the exciting developments in the Amiga world lately are only for OSes that require PPCs. But the reality is, 68k is still plenty of processing power for many tasks, including e-mail. So please don't leave us out in the cold!

comment:14 Changed 3 years ago by ikir

I join the chorus... we need IMAP4, i need the same accounts synced in my Macs and iPhone. Pop is not a solution for many of us. I really hope to see it happens on YAM and i will donate again when this day will come!

comment:15 Changed 3 years ago by damato

  • Description modified (diff)
  • Milestone changed from YAM 2.7 to YAM 3.0

comment:16 Changed 2 years ago by iuzlik@…

And yes, I would like to have IMAP support too (my primary account is at Apple and since they moved from MobileMe to iCloud, pop3 is not supported).

TDM

Add Comment

Modify Ticket

Action
as accepted .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

Nobody is currently notified about changes to this ticket.