close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#374 closed bug (foreign)

Write window crashed during editing. NListtree.mcc the culprit!

Reported by: hypex Owned by:
Priority: undecided Milestone:
Component: user interface Version: 2.8
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

Simple as it sounds. There I was editing a mail and boom. Another crash. I'm really hoping it is MUI classes and not YAM crashing as I am finding YAM 2.8 very unstable! :-?

The crashlog lists NListtree.mcc as the culprit. :-)

I could recover by ignoring DSIs but then YAM went all weird. And kept looking for a directory of the following name:

Í{÷<ùÚOwò?ëúûy¾ÿ¹¹Öï?I®Íb¦ÚE%¹o%¼ëË¿¬ü>¿ûõ?v3ûKÿµÿäçëçú ÒÁÍ Äéóëº
ö¿nóoħ=wÂÛéÿ¿íçÄÙª÷á䤩ȨçÃÿýþÿÛ®¼·ßïû·ýü×õÛÄ¿¥ö¸Õõöùñ±Ýßÿÿï¶çÿþôÝ=iîû¼NMe$#»½ñÿ|¿ÿ÷·
Äåöéãåóº
ÁÕÄÉÏ ÁÕØ ÁÕر ÃÄ° Ãı
ÃÏΠÄÈ° Äȱ Äȱ± Äȱ³
Äȱ¶ Äȱ· Äȱ¸ ÄȲ ÄȲ±
Äȳ ÄÈ´ ÅÎÖ ÉÃÄ° ÉÄÆ°
ËÃÏΠËÒÁ× ÐÁÒ Ðð ÐÉÐÅ
ÐÉÐÅÃÏΠÐÒÔ ÒÁÍ ÒÁÎÄÏÍ ÒÁ×
ÓÅÒ ÓÅÒ± Ó×ÁРÔÃРÔÅØÔÃÌÉÐ
ÕÒÌ ÕÓÂÐÒÔ 

That's crazy! I was able to assign it to RAM then hold the mail and quit YAM. I reloaded it back in and it's fine for now.

Attachments (2)

Crashlog_YAM_2013-01-15_01-26-54.txt (33.8 KB) - added by hypex 20 months ago.
Crashlog_YAM_2013-01-15_01-26-47.txt (33.9 KB) - added by hypex 20 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 45 years ago by hypex

  • Status changed from pending to new

comment:2 follow-up: Changed 45 years ago by hypex

  • Status changed from pending to new

Changed 20 months ago by hypex

Changed 20 months ago by hypex

comment:1 Changed 20 months ago by tboeckel

Can you reproduce this crash? Or was it a "one time thing" only, maybe caused by previous crashes as reported in #373?

comment:2 follow-up: Changed 20 months ago by hypex

This is another of those rare annoying crashes. But it's not related to #373. This happened in another session of YAM after a fresh bootup. And the code function differs.

It seems I always press something on the keyboard while looking at it and not the screen that triggers these rare bugs. Usually a slip onto shift or sometihng else. Perhaps I am too fast for it. Well, doubt it. :-)

I know these things really need to be reproducable but as soon as it happened I collected crash logs and wanted to report it. I can see the scientific method of bug tracking really needs to work with operational science rather than the hstorical science data I am giving you. :-D But I prefer to file some notification rather than stay silent and spend ages trying to repeat the damned thing! :-)

And, like in #373, the relevant section of code can be checked to see if a NULL pointer was accessed. However, checkting the crash logs, it's not that simple and it looks like it stepped over the edge of a data structure. Though there is a fine line between valid pointer and invalid memory soon ater it. If that is the case.

comment:3 in reply to: ↑ 2 Changed 20 months ago by tboeckel

  • Component changed from undefined to user interface
  • Milestone set to YAM 2.8p1
  • Status changed from new to pending

Replying to hypex:
Please get the updated binaries of BetterString.mcc from ticket #377. The former version has some severe bugs in it contents string handling which could cause trashed memory quite easily. Install the appropriate build and try to reproduce this issue. Although the bug in BetterString.mcc has survived lots of month without being noticed I really doubt this is a bug in NListtree.mcc. And thinking about the trashed memory by BetterString.mcc this could probably have a bad impact on NListtree.mcc.

comment:4 Changed 20 months ago by hypex

Understood. Will install and test.

comment:5 Changed 20 months ago by hypex

Okay I have been testing with new component but NList is still crashing! I am getting the exact same crash as in my first log. NList calls GetVisualPos() which masks a value with 0xffff and then tries to load an offset pointer from an illegal address.

The only difference is now that the crash can happen anytime I have the edit window open. When I am in the body.

NList.mcc 20.134 (22/12/2012)
BetterString.mcc 11.24 (20/12/2012)

comment:6 Changed 20 months ago by tboeckel

  • Status changed from new to pending

Any news on this issue?

comment:7 Changed 20 months ago by hypex

ATM YAM has been stable. But I haven't had much time for writing emails and so it may just lie dormant. However I think things are looking up! :-)

comment:8 Changed 19 months ago by damato

  • Resolution set to fixed
  • Status changed from new to closed

ok, then we will close this bug. So please reopen it if you feel the issue is back or still exists with the 2.9-dev nightly builds.

comment:9 Changed 15 months ago by damato

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 15 months ago by damato

  • Milestone YAM 2.8p1 deleted
  • Resolution set to foreign
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Damien Stewart(Reporter, Participant)