close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

#377 closed bug (foreign)

Grimreaper adding identity

Reported by: padrino Owned by:
Priority: high Milestone: YAM 2.8p1
Component: user interface Version: nightly build
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed an issue related to BetterString.mcc which cause YAM to crash.

Description

YAM 2.9-dev (19.01.2013)

  • Go to prefs to add an identiy
  • click the "+"

-> address field is active

  • press RCommand-q
  • start typing your address

-> on first char the list of matching addresses will open
-> on second char there will be the crash/GR (find log attached), no matter if the second char does still match or not.

Attachments (4)

Crashlog_YAM_2013-01-20_16-11-03.txt (29.6 KB) - added by padrino 20 months ago.
GR log
bstring_os3.lha (21.6 KB) - added by tboeckel 20 months ago.
Fixed BetterString.mcc for AmigaOS3
bstring_os4.lha (26.5 KB) - added by tboeckel 20 months ago.
Fixed BetterString.mcc for AmigaOS4
bstring_mos.lha (27.2 KB) - added by tboeckel 20 months ago.
Fixed BetterString.mcc for MorphOS

Download all attachments as: .zip

Change History (10)

Changed 20 months ago by padrino

GR log

comment:1 Changed 20 months ago by damato

  • Milestone set to YAM 2.8p1
  • Priority changed from undecided to high
  • Status changed from new to accepted

Here I could perfectly reproduce the problem. However, smells like a problem in BetterString.mcc. Needs some more investigation.

comment:2 Changed 20 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from accepted to closed

I found the problem. It is BetterString's internal handling of its string contents. There are 3 different buffers (normal, undo, original), but BetterString kept an allocation size for only one of these. Doing any action which caused the undo buffer to be used (i.e. delete a marked section) would simply swap the normal and undo pointers. However, the remembered allocation size for the former content string was still applied to the swapped string pointer with a (most probably different and smaller) allocation size and hence would trash memory.

I will attach fixed versions for AmigaOS3, AmigaOS4 and MorphOS. Please reopen this ticket if these versions still cause issues.

Changed 20 months ago by tboeckel

Fixed BetterString.mcc for AmigaOS3

Changed 20 months ago by tboeckel

Fixed BetterString.mcc for AmigaOS4

Changed 20 months ago by tboeckel

Fixed BetterString.mcc for MorphOS

comment:3 follow-up: Changed 20 months ago by padrino

Attched version crashes no more, thanks!

Version 0, edited 20 months ago by padrino (next)

comment:4 in reply to: ↑ 3 Changed 20 months ago by tboeckel

Replying to padrino:

Attached version crashes no more, thanks!

Good to hear. Is it possible this was the cause for #358, too? Or can you still reproduce that one?

comment:5 Changed 15 months ago by damato

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 15 months ago by damato

  • Release Notes modified (diff)
  • Resolution set to foreign
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mario Cattaneo(Reporter, Participant)