close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 22 months ago

Closed 22 months ago

Last modified 17 months ago

#382 closed bug (invalid)

Recoverable alert on OS 3.9 when clicking inbox list

Reported by: mikesteed Owned by:
Priority: undecided Milestone:
Component: user interface Version: 2.8
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

This problem affects YAM 2.8 on my A3000 with a Cyberstorm MKIII
(68060 @ 50 MHz), running OS 3.9.2. I have installed all of the
latest MUI components used by YAM.

The problem is not repeatable in that there is no consistent
sequence of actions I can perform that will always cause it to
occur. But in normal use of YAM to download and read email it
doesn't take long to happen. The action that seems to trigger it is
clicking on items in the list of emails in the inbox.

The symptom is a recoverable alert with the error code 0100 000C
(MemoryInsane) from the RAM disk task. The alert comes right back
when dismissed, roughly once for each item in the inbox list.
Eventually the alerts end, and YAM resumes working. But clicking
another item in the email list starts the alerts again. Sometimes
the alerts do not end, and keep repeating until I give up and
reboot.

As you might expect given the error, after encountering the problem
the system becomes unstable, and prone to malfunctions or crashing
even when using Workbench or other programs.

I installed the new version of BetterString, but that did not solve
the problem. Running CyberGuard did not show any hits until the
alerts began, after which RAM: crashed before I could capture the
CyberGuard output. The bug has likely occurred some time before
RAM: notices the problem, anyway.

Attachments (0)

Change History (13)

comment:1 Changed 45 years ago by mikesteed

  • Status changed from pending to new

comment:2 Changed 45 years ago by mikesteed

  • Status changed from pending to new

comment:1 Changed 22 months ago by tboeckel

Please get the fixed version of BetterString.mcc from #377 and make sure to set the NList scrollbars to always visible (MUI prefs -> NListviews -> Scrolling). The currently released version of BetterString is known to trash memory and due to a bug in MUI dynamic scrollbars may also cause issues each time the scrollbars are added or removed.

Please report back if these provisions fix this issue.

comment:2 Changed 22 months ago by damato

  • Status changed from new to pending

In addition, please also try to install the latets nightly 2.9-dev build because certain things have been fixed in there already which might also be a reason for the problems you report here.

comment:3 follow-up: Changed 22 months ago by tboeckel

  • Milestone set to YAM 2.8p1

I just fixed another long standing and memory trashing bug which quite easily might be responsible for this issue. So please try the next nightly build and report back here.

comment:4 in reply to: ↑ 3 Changed 22 months ago by mikesteed

I've already tried the fixed version of BetterString, and that didn't help. I'll give the other suggestions a try, and let you know how it goes.

comment:5 follow-up: Changed 22 months ago by anonymous

I get the same error with very similar configuration, it always happens during or right after downloading mail. Usually when filtering but not always. Error code is 0100 000C and the task is called RAM. I tried the scrollbar fix but the problem is still there. Will try with the 2.9-dev build.

comment:6 in reply to: ↑ 5 Changed 22 months ago by tboeckel

Replying to anonymous:

Please remember to log in the next time before you comment on something. This makes communication MUCH easier for all involved persons.

comment:7 Changed 22 months ago by tboeckel

  • Status changed from new to pending

Any news on this issue?

comment:8 Changed 22 months ago by mikesteed

I've been using and abusing the 31-Jan dev. build of YAM for almost a week,
and have been unable to reproduce the problem. So I'd say it's been fixed by
one of the changes made since the 2.8 version.

comment:9 Changed 22 months ago by jostberg

I downloaded the 2.9-dev version and the 0100 000C is gone.

comment:10 Changed 22 months ago by tboeckel

  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket as "invalid" then.

comment:11 Changed 17 months ago by damato

  • Milestone YAM 2.8p1 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Mike Steed(Reporter, Participant)