close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 18 months ago

Closed 18 months ago

Last modified 13 months ago

#390 closed bug (fixed)

Crash while aborting remote filtering

Reported by: hypex Owned by:
Priority: undecided Milestone: YAM 2.8p1
Component: mail filtering Version: 2.8
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

modifiered remote filters to be applied when getting the single message details. This makes it possible to let the filters check all available information but it also requires the user to wait until the details of all new mails have been received. Otherwise it could have happened that some mails were not received although they should be filtered out.

Description

Hello. Was testing and just getting a remote filter working. But it was taking too long communicating with mail server and sending data back or forth. So I pressed Abort.

First YAM told me the mail server reported some error about the QUIT comand and it spewed back some unreadable text. Looked like MIME format.

YAM then crashed. Let it run again. Crashed. Tried to ignore DSIs and let it recover. Too far gone, YAM froze, and I had to reboot. But ti did manage to put the preview window up with a corrupted list of items. Looked like random memory in strings.

YAM 2.8 (24/12/2012)
Copyright (C) 2000-2012 YAM Open Source Team [OS4/PPC, r6476]

NList.mcc 20.134 (22/12/2012)

muimaster.library 20.2347 (20/01/2013)
(c) 1992-2010 Stefan Stuntz, et al. [AmigaOS4/PPC] [svn r2394]

Change History (16)

Changed 18 months ago by hypex

Changed 18 months ago by hypex

comment:1 Changed 18 months ago by tboeckel

  • Milestone set to YAM 2.8p1

comment:2 Changed 18 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from new to closed

(In [6602]) * tcp/pop3.c: remote filters are now applied when getting the single message details. This makes it possible to let the filters check all available information but it also requires the user to wait until the details of all new mails have been received. Otherwise it might happen that some mails will be received although they should be filtered out. This closes #390.

comment:3 Changed 18 months ago by tboeckel

Please check again with the next nightly build. Unfortunately I was not able to reproduce any crashes, hence I am not 100% sure whether these are fixed as well or not.

comment:4 follow-up: Changed 18 months ago by hypex

Okay checked with 2.9 debug R6608 and the problem still persists.However this time the Selection window pops up over the Transfer window. The Selection window shows no sign of remote filtering or results as it lists each new mail.

Pressed abort in Transfer window and it crashed. Collected five logs.

Last edited 18 months ago by hypex (previous) (diff)

comment:5 Changed 18 months ago by hypex

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 18 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6618]) * mui/TransferMailList.c: added some NULL checks to fix #390 again.

comment:7 in reply to: ↑ 4 Changed 18 months ago by tboeckel

Replying to hypex:

Okay checked with 2.9 debug R6608 and the problem still persists.However this time the Selection window pops up over the Transfer window. The Selection window shows no sign of remote filtering or results as it lists each new mail.

Unfortunately I am still not able to reproduce the crashes myself. But according to the crashlogs thereis a NULL access happening. This will be fixed in the next release.

Let me explain how remote filters work. Usually all new mails on the server will be marked as "to be downloaded" and "to be deleted" (unless the "delete mail on server" option is disabled). Remote filter can invert exactly these two flags and hence cause mails to be not downloaded or to be deleted. The filter will be applied when YAM has received the single mail details (sender, subject, etc). You will only notice the effect of the remote filter if it really did change one of the two flags.

comment:8 Changed 14 months ago by damato

  • Release Notes modified (diff)

comment:9 Changed 13 months ago by hypex

Well that covers what I want, if I understand correctly, for my filter to leave certain emails on the server. I'll do some more testing.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Damien Stewart(Reporter, Participant)