close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 18 months ago

Closed 18 months ago

Last modified 15 months ago

#392 closed bug (invalid)

Getting mails from gmail,

Reported by: mlehto Owned by:
Priority: undecided Milestone:
Component: undefined Version: 2.8
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Description

I have old gmail account full of mails, roughly 1300.

gmail is set up to allow pop/access.

Account itself works.

When I get mails from gmail, YAM find somewhere 100-300 mails. Takes them. Not find all.

Set up is, that it leaves mail to server.

When I get them again, it again finds some mails and start to get them.

Obviously YAM cant separate new mail from olds, because all in all I got 1600 mails repeating get many times, where 1300 is possible.

Somehow YAM and gmail communication is broken, I think.

When I set up as gmail allow pop/acces from that moment, everything goes well and only new mail arrive.

Other thing was, that at least at time, when I tried to get all old mails from server, all was marked as spam and moved to spam-folder.

Attachments (0)

Change History (7)

comment:1 in reply to: ↑ description ; follow-up: Changed 18 months ago by tboeckel

  • Milestone set to YAM 2.8p1

Replying to mlehto:

When I get mails from gmail, YAM find somewhere 100-300 mails. Takes them. Not find all.

YAM will remember which mails it already did download from the POP3 server and will skip them on the next POP3 download in case they were left on the server. There is no point in downloading thousands of mails over and over again, isn't it?

Somehow YAM and gmail communication is broken, I think.

If you think the communication is really broken then start YAM from a shell with the DEBUG option. YAM will then print the complete communication between your machine and the server to the shell. This should reveal if there is something going wrong. Just redirect this output to a file and attach it to this ticket (i.e. YAM debug >t:gmail.log)

Other thing was, that at least at time, when I tried to get all old mails from server, all was marked as spam and moved to spam-folder.

The spam filter must be trained to be able to tell "good" mails and "bad" mails apart. That means that in the beginning many mails will falsely be treated as spam even if they are normal mails. You then have to tell YAM the truth about these mails by declaring them as "no spam" (or by declaring false negatives as true "spam"). This will train the filter and improve its spam recognition abilities with every new mail.

comment:2 in reply to: ↑ 1 Changed 18 months ago by tboeckel

Replying to thboeckel:

If you think the communication is really broken then start YAM from a shell with the DEBUG option. YAM will then print the complete communication between your machine and the server to the shell. This should reveal if there is something going wrong. Just redirect this output to a file and attach it to this ticket (i.e. YAM debug >t:gmail.log)

Just one additional note. If you are going to attach such a log here please make sure to remove personal stuff like passwords from it. The log will contain unencrypted passwords. So please don't complain if you forgot to remove this stuff and somebody hacks your mail account!

comment:3 Changed 18 months ago by tboeckel

  • Resolution set to invalid
  • Status changed from new to closed

I just did some tests with my own googlemail account and although YAM is configured to leave all mails on the server they will be deleted nevertheless as soon as they are downloaded via the POP3 protocol. But this deletion is NOT caused by YAM. This seems to be done automatically by googlemail.

Thus there is nothing wrong in YAM. I am sorry, but there is nothing we can do about such an "automatism". Direct your complaints to googlemail directly.

comment:4 follow-up: Changed 18 months ago by tboeckel

Enable the "recent" mode to download mails to more than just one single device: http://support.google.com/mail/answer/47948?hl=en

comment:5 in reply to: ↑ 4 ; follow-up: Changed 18 months ago by damato

Replying to thboeckel:

Enable the "recent" mode to download mails to more than just one single device: http://support.google.com/mail/answer/47948?hl=en

As questions about this and similar observations might come up I guess it would be a good idea to create a new FAQ entry about that. Opinions?

comment:6 in reply to: ↑ 5 Changed 18 months ago by tboeckel

Replying to damato:

As questions about this and similar observations might come up I guess it would be a good idea to create a new FAQ entry about that. Opinions?

You know my usual answer: go ahead ;) A FAQ entry for this special case is real worth being added.

comment:7 Changed 15 months ago by damato

  • Milestone YAM 2.8p1 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

Nobody is currently notified about changes to this ticket.