close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#402 closed bug (fixed)

Identities mixup problem (YAM 2.8p1, MorphOS)

Reported by: DrB Owned by: tboeckel
Priority: normal Milestone: YAM 2.9
Component: mail filtering Version: 2.8p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

Fixed a bug which caused YAM to use the first matching address of a mail as user identity even if this address was the sending instead of the receiving one.

Description

This is a splitup related to ticket 401 (part 2).

Let's assume, I've two identities, Mr.A @ mydomain.com and Mrs.B @ mydomain.com. Let's also
assume, Mrs.B is on holiday and is sending an email to Mr.A (which is using yam). If Mr.A now
answering to the email from Mrs.B, yam uses the identity of Mrs.B for the reply (and not Mr.A,
which would be correct).

Attachments (0)

Change History (6)

comment:1 Changed 18 months ago by tboeckel

  • Status changed from new to accepted

So far I am still not able to reproduce this issue myself.

Please create a MAIL debug log using the debug version of YAM while reproducing the issue and attach it here. I suppose replying to the mail is enough to trigger the bug, correct?

comment:2 follow-up: Changed 18 months ago by DrB

Ok, I've created full debug log (all) starting with pressing the reply button. It contains the wrong identity
selection, but I don't want to put this to the pubic, because it contains private information like email
addresses, etc. and I don't want to anonymise them, because they are important for this bug. So
it's better when you tell me an email address where I can send the log.

Btw, when looking to the log, the first match seems

00:D: YAM_MAf.c:2374:finduinByAddr: 'Some.Name@…' 247da8e4

Seems, that you first check the "mail->From.Address" (line 2374) before "mail->To.Address" (later in line 2495),
at this time email->identity is already defined.

Version 0, edited 18 months ago by DrB (next)

comment:3 in reply to: ↑ 2 Changed 18 months ago by tboeckel

  • Component changed from undefined to mail filtering
  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Priority changed from undecided to normal
  • Status changed from accepted to assigned

Replying to DrB:

Btw, when looking to the log, the first match seems

00:D: YAM_MAf.c:2374:finduinByAddr: 'Some.Name@…' 247da8e4

Seems, that you first check the "mail->From.Address" (line 2374) before "mail->To.Address" (later in line 2495), at this time email->identity is already defined.

That was the hint I was looking for! You are right. YAM catches the first matching address as user identity. The point is that the header lines may appear in arbitrary order and hence the wrong identity might be used.

comment:4 Changed 18 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6688]) * YAM_MAf.c: while doing a deep examination of a mail YAM will no longer use the first matching address as the mail's user identity but collect all possibly matching identities at first, because the header lines can appear in arbitrary order and hence it is unpredictable which header line eventually produces the used identity. After scanning all headers the identity will be chosen in a predicatable way which prefers the "receiving" addresses. This closes #402.

comment:5 Changed 18 months ago by tboeckel

  • Release Notes modified (diff)

comment:6 Changed 18 months ago by tboeckel

  • Release Notes modified (diff)

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Andreas Schwarz(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)