close
Comments you submit will be routed for moderation. If you have an account, please log in first.
Modify

Opened 16 months ago

Closed 15 months ago

Last modified 12 months ago

#413 closed bug (fixed)

ISI crash on Reload arrangement

Reported by: samo79 Owned by: tboeckel
Priority: undecided Milestone: YAM 2.9
Component: user interface Version: 2.8p1
Severity: major Keywords:
Cc: OS Platform:
Blocked By: Blocking:
Release Notes:

fixed a problem when YAM was run for the very first time after an installation without any valid .config file. Opening the config window too early caused this window to be opened without any graphics from the default theme.

Description

The reload arrangement (accessible via right click on the folder list column at the left) seems a bit stable from time to time, i already experience some related but not so problematic DSI, but now i had also an ISO one

What is strange is that the issue is not always reproducible but it happen also in a perfecly clean YAM installation (aka no mail at all received nor sended)

Attachments (5)

Crashlog_YAM_2013-08-26_05-23-09.txt (30.7 KB) - added by samo79 16 months ago.
ISI crash
Crashlog_YAM_2013-09-10_10-01-29.txt (31.8 KB) - added by samo79 15 months ago.
DSI crash
no_icon_config.png (648.0 KB) - added by samo79 15 months ago.
No graphics in prefs window
Crashlog_YAM_2013-09-17_21-01-04.txt (28.9 KB) - added by samo79 15 months ago.
Reload arrangement crash
Crashlog_YAM_2013-09-20_06-06-41.txt (28.1 KB) - added by samo79 15 months ago.
Crash on nightly build (2013-09-20)

Download all attachments as: .zip

Change History (25)

Changed 16 months ago by samo79

ISI crash

comment:1 Changed 16 months ago by tboeckel

  • Milestone set to YAM 2.9
  • Owner set to tboeckel
  • Status changed from new to assigned

comment:2 Changed 16 months ago by damato

Please note, that with ticket #284 this ticket will be automatically solved as the reload functionality will be removed then,

comment:3 Changed 16 months ago by samo79

@damato

Ok fine, however now i'm not 100% sure if the problem are really related to the arrangement functionality, some days ago i got a similar issue but just selecting one of the folder .. (i already reported the issue to Thore)

Maybe isn't related at all, or maybe is related ?
Need to verify (but first i need to reproduce the error)

Last edited 16 months ago by samo79 (previous) (diff)

comment:4 Changed 16 months ago by tboeckel

So far I was not able to reproduce this issue myself. Maybe you were a victim of trashed memory caused by other applications?

comment:5 Changed 16 months ago by samo79

@Thore

I don't think so as i was able to reproduce the crash only having YAM opened and nothing else, however the latest nighly builds does not start anymore on my system (see new ticket 416 for more info) so i wasn't able to test if the latest nightly fixed it

So i downloaded and tested YAM 2.8p1 and the stable version does not produce any crash reloading the arrangement, the crash on the reload arrangement might be an issue added in recent nightly build (?) ..

comment:6 Changed 16 months ago by tboeckel

What about reproducing this issue now after #416 is fixed?

Changed 15 months ago by samo79

DSI crash

Changed 15 months ago by samo79

No graphics in prefs window

comment:7 follow-up: Changed 15 months ago by samo79

Here is me again :-)
Sorry for delay, it was a busy week !

I just retried with the very latest nightly build (2013-09-13) and i was NOT able to reproduce the issue anymore.
Of course i'm not sure if the issue is really fixed in meantime, so i'm doing some more test ..

However atleast with an old nightly (2013-09-09 for example) i had a DSI crash when i try to reload the arrangement!

See log attached

To reproduce it i just reinstalled YAM 2.8p1 in a clean partition and then i've updated it to a recent 2.9 nightly.

The config was of course empty (no configured), so no mail sent/received at all, aka my YAM installation was and still completely clean

Aniway above this specific issue i also noted that at first start the preferences window of YAM does not show the icons (see grab)

Instead if i close the prefs window and then i reopen it again the icon will be showed normally, please can you fix it aswell ?

comment:8 Changed 15 months ago by tboeckel

(In [7055]) * YAM.c: moved the validation of the config after loading the configured theme. This solves the problem when YAM is run for the very first time after an installation from scratch without any valid .config file. Opening the config window too early will leave this window without any graphics from the default theme otherwise. This refs #413.

comment:9 in reply to: ↑ 7 Changed 15 months ago by tboeckel

Replying to samo79:

I just retried with the very latest nightly build (2013-09-13) and i was NOT able to reproduce the issue anymore.
Of course i'm not sure if the issue is really fixed in meantime, so i'm doing some more test ..

Ok, I am going to close this ticket as "fixed" in the meantime. If the crash should happen again then please reopen this ticket.

Aniway above this specific issue i also noted that at first start the preferences window of YAM does not show the icons (see grab)

This is fixed with my latest change.

Instead if i close the prefs window and then i reopen it again the icon will be showed normally, please can you fix it aswell ?

I did. But please open a new ticket for such an issue next time, because there is absolutely no relationship between a crash after a certain action and missing icons. Mixing several unrelated bugs in a single ticket might result in bugs to be forgotten.

comment:10 Changed 15 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:11 follow-up: Changed 15 months ago by samo79

Ok thanks for the theme fix, will try the new build tonight and eventually, if still i will open another ticket for the reload arrangement issue :-)

comment:12 in reply to: ↑ 11 Changed 15 months ago by tboeckel

Replying to samo79:

Ok thanks for the theme fix, will try the new build tonight and eventually, if still i will open another ticket for the reload arrangement issue :-)

Sorry, but you still got me wrong. For the "reload arrangement issue" you should reopen THIS ticket, because this ticket already is about the "reload arrangement issue". However, for any other issue whatsoever please open a NEW ticket.

comment:13 Changed 15 months ago by samo79

Ah ops !

Changed 15 months ago by samo79

Reload arrangement crash

comment:14 Changed 15 months ago by samo79

Ok i was able to reproduce the issue, however reproduce it still rather difficul (casual ??), because it is presented in a inconsistent manner (sometimes it crash and sometimes not for no apparent reason!)

The only thing I've realized is that you do not need to do a Reload arrangement in a specific folder, even click on a column can be enough

So right click with the mouse -> Reload arrangment

Repeat the operation some times again and again and after a while you should have the crash !

comment:15 Changed 15 months ago by tboeckel

I reloaded my folder tree about a 100 times by now, but for me there is no crash or memory corruption at all. Please try again with the next nightly build, as I just changed a minor thing abd used that version for the test, which might have an impact on this issue.

comment:16 follow-up: Changed 15 months ago by samo79

Problem still also with the latest nightly build (2013-09-20) however the crash seems less reproducible now

As before (as test) i reloaded the folder tree many time but i got a crash only when i reopen YAM after an iconification --> (i was using the system with other program in background)

Changed 15 months ago by samo79

Crash on nightly build (2013-09-20)

comment:17 in reply to: ↑ 16 Changed 15 months ago by tboeckel

Replying to samo79:

Problem still also with the latest nightly build (2013-09-20) however the crash seems less reproducible now

As before (as test) i reloaded the folder tree many time but i got a crash only when i reopen YAM after an iconification --> (i was using the system with other program in background)

Sorry, but I am still not able to reproduce this. No matter how often I reload the folder tree and/or (de)iconify YAM everything is absolutely stable.

The strange thing about your latest crashlog is the fact that the crash happens in 68k code instead of PPC code. There is really something fishy happening on your side.

comment:18 Changed 15 months ago by samo79

Strange, all can i do at this point is retry with a clean OS installation... in that case i think we should wait some time for that test --> aka when i need to reinstall the OS --> not so far :-)

comment:19 Changed 12 months ago by damato

  • Release Notes modified (diff)

comment:20 Changed 12 months ago by damato

  • Version changed from nightly build to 2.8p1

Add Comment

Modify Ticket

Action
as closed The owner will remain tboeckel.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber

  • Samir Hawamdeh(Reporter, Participant)
  • Thore Böckelmann(Owner, Participant)